Sign in with
Sign up | Sign in
Your question

Can't see WD Green 2TB 3,5" HDD

Last response: in Storage
Share
December 10, 2012 2:22:50 PM

Today I bought a used WD Green 2TB 3,5" HDD( WD20EARS-00MVWB1 ). It has 9500 Hours of usage and I just hooked it up to my computer.
I now have the problem that the HDD doesn't show up at all. This is what I have done so far:
I have 2 extra slots on my PC for HDD's and used one of these for the first time now. First i thought maybe the plugs weren't fitting right so I opened my pc and plugged the drive in manually. Still nothing.
I looked at the Device Manager and Computer>Manage>Disk Management but it just wont show.

Now I have no idea what could be wrong. Any suggestions? Can provide(or make) pics of plugs, etc if needed.

Thanks in advance
lega

More about : green 2tb hdd

a b G Storage
December 10, 2012 2:41:53 PM

Go into BIOS (del key or F2 during boot) and see if it shows up there. While in BIOS make sure all your SATA controllers are enabled. If it can't see it in BIOS it's a bad drive.

Try it on another PC, too.
December 10, 2012 4:14:34 PM

Yeah I tried that. Doesn't work - The Sata Controllers are set to auto detect and don't seem to find anything.
Related resources
December 10, 2012 5:56:13 PM

Okay I'm just supid. I traced the wrong power cord... it wasn't even hooked on to the psu.
But it still don't works. And I am not entirely sure if I connected it right.

The power cord that goes away from the HDD looks like this: http://compare.ebay.de/like/300590431998?var=lv&ltyp=Al...

I connected the middle one to the opposite from the psu. Should i connect the second one two?
a b G Storage
December 11, 2012 12:15:05 PM

Usually you only need to connect one of them to the power supply cable. But go ahead and connect both of them to separate molex (4 pin) connectors on different lines from the power supply. That should do it.
!