Sign in with
Sign up | Sign in
Your question

Black screen after downloading ATI catalyst

Last response: in Graphics & Displays
Share
July 29, 2010 7:04:16 AM

Hello,
I just downloaded the ATI catalyst on my other computer, the download went well, then it told me to reboot my computer after it came back on there is a black screen, I have no visual at all. I waited a couple of hours with the computer on then rebooted again and still have a black screen, does anyone know how to fix this problem

Windows vista 32 bit
ATI radeon HD 3450
ask for more specs if needed
July 29, 2010 7:43:01 AM

xNoXiOuS said:
Do you have the same issue when you boot up in safe mode? I would try to reinstall the drivers in safe mode and see if that fixes your issue. The official drivers are here http://support.amd.com/us/psearch/Pages/psearch.aspx?ty... -- Not sure if you went there or not.

How do you boot in safe mode? Because I can't see anything on the screen at all
Related resources
July 29, 2010 8:58:13 AM

Quote:
How do you boot in safe mode?


On startup post, hit F5, then F8.

IMO, Cat 10.7s are shite. I had similar problems.

Stick with Cat 10 10.3 or 10.4.

Use driver sweeper (from Guru 3D) to uninstall drivers.

Good luck.
July 29, 2010 9:48:29 AM

Agree, if you had problem with the latest driver then roll back with the older one...
July 29, 2010 6:57:00 PM

This is exactly the sort of thing I only hear of on ATI cards. Their drivers are crap and always have been. If I were you I'd get an Nvidia card and start over.
July 30, 2010 3:37:16 AM

^
Nvidia also have their own problem with driver...
Nothing's perfect... :) 
!