Velocity External HDD converter: disc suddenly does not spin up at all

Hi all. I bought a Velocity external HDD enclosure a while back for my old 2.5" drive that was in my laptop, which is now using an SSD. It worked just fine with the cable supplied, a y-type USB cable, but I bent the end and it broke off due to my stupidity. The baffling thing here is that the drive will not spin up at all with any other ordinary USB cable I've tried with it. This is ridiculous. I don't understand why the USB cable that came with it should work and none else should. Is it dark wizardry, or is something afoot here?
2 answers Last reply
More about velocity external converter disc suddenly spin
  1. A standard USB 2.0 port is current limited to 500mA, while a USB 3.0 can supply 900mA. A Seagate ST9500325AS drive, for example, requires about 850mA during spinup, and about 400mA thereafter. A Y-cable is therefore sometimes necessary to pick up power from two USB ports.
  2. The weird thing is that I didn't even use both ends of that y cable, I just used the one and it worked. It doesn't now.
Ask a new question

Read More

Hard Drives USB Cable External Hard Drive Storage