Hard drive not showing up in BIOS boot options

Hello, I am using a ASUS U47A laptop wit Windows 7 64 bit premium. I installed Fedora 17, or shall I say tried to, and then at the end of installation it requires a reboot, so I did. But here is the problem. The BIOS will no longer recognise the hardrive as a boot option. It detects the harddrive fine as in port 0, but it does not show up in boot priority list. The only way to boot is through the CDROM in port 2.

The hard drive can also be detected from a live desktop and all files accessible, I just can't seem to boot into the windows or Fedora system on it.

Does anyone know what the issue might be and how can I fix it?

Thank you!
5 answers Last reply
More about hard drive showing bios boot options
  1. Disable UEFI in your BIOS. Or else install Linux with UEFI enabled.
  2. Update bios it can solve the issue. if not solved the sata port in mobo was making this problem .so contact manufacturer to fix this or change sata port from mobo can high cost and install windows.if laptop is under warenty u can get all services for free.
  3. Try going into the BIOS to the boot menu area and go to the "Delete Boot Option" and then delete all entries and save and exit.
  4. hst101rox said:
    Try going into the BIOS to the boot menu area and go to the "Delete Boot Option" and then delete all entries and save and exit.


    THANK YOU.
  5. Ivan_19 said:
    hst101rox said:
    Try going into the BIOS to the boot menu area and go to the "Delete Boot Option" and then delete all entries and save and exit.


    THANK YOU.

    Your Welcome!
Ask a new question

Read More

Hard Drives Boot Storage