Sign in with
Sign up | Sign in
Your question

Video, Disk and delay problems

Last response: in Systems
Share
September 5, 2010 2:42:32 PM

Back in 2007 I built a PC. The current specs are:

Windows 7 64-bit
Core2Quad @ 2.4
4 GB DDR2
Gigabyte P35-DS3L
XFX GeForce 8800 GT / 512MB
150 GB Raptor
Lite-ON DVDRW
I don't recall what the PSU was, but it was at least 700W.

Summary of disk issue: Windows AND BIOS don't recognize hard drive without Linux having first seen the disk.
Details:
I recently added a 1TB WD Black HDD. The WDB was recognized, Windows installed drivers and life is beautiful. Fast forward a week and on boot up the BIOS is saying that my 1TB drive is 33MB in size. I checked the BIOS version and this was out of date, the version I had seemed to have problems with 1 TB drives. I flash to the latest and greatest version and the problem is still there. I used an Ubuntu Live CD (10.04) and ran the disk manager. It shows my WDB Disk is 1 TB in size, I mount the disk and everything I put on it is there. I reboot the machine and go into BIOS which now properly displays the 1TB size and go into Windows and the drive is there and working flawlessly. What gives?
I contacted WD about this, they told me to run their tools. I shut the machine down, boot it up and the BIOS and Windows both say its 33MB again. I run the tools and those tools say the disk is 33MB and that it's working perfectly. I tell WD this and they say it's obviously a problem with Windows because it worked under Linux so contact MS. That's probably going to be just as pointless.

The video/delay issue:
When I cold boot my machine up I hear the fans come on and spin up for like 10 seconds and THEN the POST comes up. If I don't immediately reboot my machine by pressing reset button Windows starts to come up and I BSOD with the Nvidia driver being the problem. If I do soft-boot the machine POSTS instantly and I go into Windows problem free.

Any ideas/thoughts would be appreciated. Sorry about the length.
a b B Homebuilt system
September 5, 2010 2:54:57 PM

More likely that it's a problem with how it's formatted. Try reformatting.

I had this happen in reverse once, I put a 1.5 terabyte drive into my home server. It couldn't tell how large it is, (running 8.04), so I just put in a live CD to format it and it worked fine.

But yeah it doing it in the BIOS doesn't make it a windows only problem. You did format it when you had a faulty anti-tera drive BIOS.
m
0
l
September 5, 2010 3:17:07 PM

Thanks for the reply, Dmitry.

I'm not sure I see the correlation between the BIOS and a format before and after the update. I've moved drives from one machine to another in the past which had completely different BIOS' and I didn't need to reformat them... The FS is NTFS, btw. I think if there were any relationship then clearing the BIOS should work equally well. I can give that a try and then try to reformat. I have a lot of stuff on it and moving it off will be a pain.
m
0
l
a b B Homebuilt system
September 5, 2010 7:10:57 PM

Alot of the time when I fix something one of the first things I think is "this would be incredibly stupid if this were the problem" then about half the time it was. So it's worth trying.

What I'm suggesting though is that perhaps the faulty BIOS wrote something wrong into the drive because it fumbles handling drives that large. Linux seems able to ignore/bypass alot of stuff on host systems. Like if you have cool'n'quiet off in the BIOS ubuntu still throttles it exactly like it would had it been on.
m
0
l
!