Sign in with
Sign up | Sign in
Your question

Radeon 5970, one GPU is not working.

Last response: in Graphics & Displays
Share
July 31, 2010 8:08:48 PM

When I checked with MSI Afterburner, I found that one GPU of my Radeon 5970 is not working. And the games stops after playing some time.
Catalyst AI is enabled. and I tried with the latest CCC 10.7.

And in AMD Overdrive, I saw that the temperature and voltage field are disabled.

Any ideas???
a c 130 U Graphics card
July 31, 2010 8:23:54 PM

Don't know a whole lot about this but simple things like is Crossfire selected in the drivers would be a good place to start. Does this happen in just one game or in a selection ? If its a single game google to see if there are issues with Crossfire support for that game.
Did it work before ok but the Driver update has screwed it up ? If so roll back the driver and see if its ok again. If it is leave the drivers on the old ones.
Mactronix
a c 169 U Graphics card
July 31, 2010 8:31:01 PM

What's your OS ?
Also open CCC>Information center and select "Graphic hardware" tab,you have to see either "Primary adapter" and "Linked adapter" or "Primary adapter" and "Disabled adapter",which one is available there ?
Also what do you mean the game stop after playing ? do they crash ? do they give any error ?
Related resources
July 31, 2010 8:45:57 PM

Everything was fine before I replace my main board. The board is same model as old.
In CCC I could see both primary adapter and linked adapter. The game freezes and then closes after some seconds.

I ran heaven benchmarking and monitored the GPU's . Only one is working 100% always... and the other is just idle most of the time and some times around 10%.
July 31, 2010 8:51:52 PM

OS is Windows 7. And the main board is Gigabyte 890GPA-UD3H.
July 31, 2010 10:16:07 PM

After uninstalling the CCC, both GPU's are working perfectly..... AMD should fire their driver developers.....
July 31, 2010 11:09:51 PM

I've restored my machine to Catalyst CC 10.4 and now it's working perfectly.......

I think 10.6 and 10.7 has got some bugs.... AMD,,,,,, are you listening ???????
!