Recover Data from External HD

We had as Seagate 3tb external drive stop responding. Took it out of it's case and stuck it in a Cavarly Hard Drive Duplicator. The computer recognizes the drive but wants to reformat it.

Went to disk management and saw this, it's drive D:

This drive was only one partition.

Anything I can do to restore the data?

Help appreciated!
9 answers Last reply
More about recover data external
  1. The USB-SATA bridge firmware in Seagate's 3TB GoFlex externals is configured with 4KB LBAs. This is to allow them to be compatible with Windows XP. If you remove the drive from its enclosure and attach it directly to a SATA port on your computer's motherboard, then you will be exposing the drive's 512e LBAs. Sector 0, where the partition table resides, will still be in the same place, but every other sector location will be out by a factor of 8.

    The actual capacity is ...

    349.31 x 8 = 2794.48 GB

    In short, you need to reinstall the drive in its enclosure, or find another enclosure that defaults to a 4096-byte sector size.
  2. I keep getting this message which I guess refers to fzabkar's response:

    "The request could not be performed because of an I/O device error."

    Tried reformatting and nothing but this. I'll give it a shot tomorrow in the original case.
  3. I got the drive back in it's case. Disk Management see's it but everytime I try to initialize the drive it says the same thing.

    "The request could not be performed because of an I/O device error."

    Any ideas?
  4. "Initialisation" is data destructive. It deletes the entries in the partition table.

    That said, the error message is implying that Disk Management is unable to write to sector 0. Is Disk Management now reporting the correct size for the physical drive? Does it detect an existing 3TB NTFS partition?

    Can you access the drive using a disc editor?

    HxD - Freeware Hex Editor and Disk Editor:

    DMDE (DM Disk Editor and Data Recovery):
  5. use fzabkar answer
  6. Tried the HxD editor and it had the same error as disk management.

    As for disk management, no it does not recognize it as a NTFS partition.

    And still comes up to the I/O Error when trying to initialize the disk.

    Any other things I can try?
  7. The fact that you can access sector 0 when the drive is outside the case but not when it is inside would suggest that there is something wrong with the case, or perhaps there is some kind of security issue (password, write protection, access rights).

    Disk Management appears to be correctly detecting the drive behind the USB-SATA bridge board inside the enclosure.

    How does HD Sentinel see the drive?
  8. yuo could try this partition recovery free to see if drive will be detect
Ask a new question

Read More

Hard Drives External Drive Storage