Sign in with
Sign up | Sign in
Your question

Buffalo MiniStation Extreme cant recognise 3.0usb

Last response: in Storage
Share
December 15, 2012 3:30:50 AM

The problem lies with its 3.0 usb port. I tried it with my acer latop and it have 2 usb2.0 and 1 usb3.0 port. aparantly i plugged it in to both the 2.0 port and it worked. however when i plugged it to the 3.0, green light appears instead of the 3.0usb blue light that is shown on the harddrive itself.

I tried it also with my late 2012 macbookpro which comes with the blue usb port. it still gives off green light. This happened today and previously it was working fine.

Recently my harddrive also had this error that it says the volume is dirty, and i can't delete any files. i had to replug it in, scan and fix from the autoplay, then it works. I tried formatting it again but still it kind of comes back once in awhile. My harddrive is formatted to exfat instead of NTFS cause i had to put stuffs in my acer/mac vice versa.

Any help would be appreciated. Thanks!
!