Sign in with
Sign up | Sign in
Your question

Ati 4870x2 FPS issue Help!!!

Last response: in Graphics & Displays
Share
August 2, 2010 2:56:01 AM

Hello!
I have some fps issue with my ATI Radeon 4870x2. When I had 4870 512 MB, and played Unreal tournament 3 with max settings on resolution 1680 x 1050, I got 60 fps all the time, but now I've much less with the 4870x2 (37 fps in the middel of battle). Regardless of which game I play except Crysis only one GPU core is in use temp 84 c the other one att 64 c. I've play starcraft 2 also and same story. Now I wondering what is wrong.

Plzz help me!!

My system specification:

MB: Asus P5Q SE2
CPU: Core 2 Duo E8200 @ 3.82 Ghz (V 1.325) temp during gaming 55 c at max
Memory: Mushkin XPS - 8500 whit timings 5-5-5-15 @ 955 (V 1.2) duo to CPU oc
HDD: Samsung 1TB F1 for system and 2x 1TB F3 for backup
GFX: Asus Ati Radeon 4870x2 2GB @ stock
Sound card :Sound Blaster X-Fi Fatal1ty Professional Series
PSU: Thermaltake Toughpower 750W
Chassi: Cooler Master HAF 932

More about : ati 4870x2 fps issue

August 2, 2010 7:13:04 AM

Hello and welcome to the forums
Did you remove the drivers of your 4870 before installing 4870X2 ?
Also open CCC>3D>AI, and make sure "Disable catalyst AI" is unchecked.
August 2, 2010 7:42:49 AM

Maziar said:
Hello and welcome to the forums
Did you remove the drivers of your 4870 before installing 4870X2 ?
Also open CCC>3D>AI, and make sure "Disable catalyst AI" is unchecked.


Hello, and thank you for answering so quickly! Yes I've removed the drivers. I hade Vista 32 bit before and now I've Windows 7 64 bit. So everything is fresh installed and the AI is enabled. I tried to set it to advance in oder to solved the problem but it did't helped :( 

excuse me for my bad english:p 
Related resources
August 2, 2010 9:27:20 AM

Do you have the latest VGA drivers installed ?
Also Disable Catalyst AI and run UT3 again and check if your FPS becomes lower or not.
August 2, 2010 6:13:24 PM

Thank you for your help!! I disabled the AI and now UT3 is runing at 60 fps, but still only one GPU is ben used. And when I run starcraft 2 its still the same.
August 2, 2010 6:26:23 PM

Catalyst AI is what enables Crossfire on that card, though some games have compatibility issues with it thus turning it off helps.
August 2, 2010 8:02:14 PM

+1^ Catalyst AI disables/enables CrossFire,so when you disable it,one GPU will work.
In some games disabling catalyst AI improves the FPS,because the game doesn't scale well with Crossfire.
I have a 5970 and for some old games like PES 2010 or COD4,when i disable Catalyst AI,i get better performance, but in newer games i can play fine with AI enabled.
August 2, 2010 9:36:15 PM

Yeh, but what about SC2? It is a new game and I think it supports crossfire.
August 3, 2010 12:22:18 AM

One more question, do I need a faster CPU like Core 2 Quad Q9650 to use both of GPU cores?
Anonymous
August 3, 2010 2:26:29 AM

no, there should be no bottle neck and it will be fine
August 3, 2010 3:27:04 AM

So what can I do to use both of my GPU cores in game? I've seen in other graphic charts where they got much higher fps then me whit everything at max settings whit highest resolution on UT3 and in Crysis on 1080p whit highsettings, I only use 1680*1050. How can it be?
August 3, 2010 8:33:48 AM

So you get better performance in "all" games with AI disabled ?
August 6, 2010 3:28:12 AM

Almost, except Crysis. I want to know why both GPUs are not in use in other games except Crysis. I played Blur a couple of hours ago and I was forced to disable the AI in CCC in oder to get bettre fps. I mean all those games supports muliti graphics cards why can't I use them?

And why does Heaven Benchmark 2.1 says: GPU model: ATI Radeon HD 4870 x2 8,753,5,0 CrossFireX 1024 Mb? It has 2gb of Vram! ( AI is enabled) divers: 10.7
And score 1931 (whit settings 1680x1050 full sreen shaders and texters are high, filter: trilinear . AF 4x. Occlusion enabled. Refraction: enabled and volumetric: enabled and rest disabled) is it ok for my system or should it be more?

thank you for your help!
August 6, 2010 9:48:14 AM

If it only works with Crysis and all other games run better with AI disabled,then there maybe a problem with the second GPU,so you may want to RMA it
August 8, 2010 8:52:17 AM

I downloaded divers 10.4 and now every game works fine whit AI enable :D  , except UT3 :(  and I got better FPS i Crysis aswell!!
Tanks for all your help!!!!
August 8, 2010 9:15:50 AM

Well it seems UT3 doesn't like your second card very much :D  but like i said,the same thing happened to me in some games(and many other users i checked in the forums)
When you want to download the VGA driver,always make sure that you download the "CrossFire profiles" too
August 8, 2010 9:54:01 AM

Ok, I did't find any "CrossFire profiles" only crossfireX profiles. I inestald it and it did't helped:( 

I forgot to mention that I've same problem whit Blur to. Disable AI it runs great w/ AI enabled no good:( 

Edit: I've only one graphicscard not two, only one 4870x2 not 2 4870s.
August 8, 2010 2:50:51 PM

I meant CrossFireX sorry.
4870X2 is one card but it has 2 4870 cores on it, and if most games don't work fine with AI enabled, then there maybe a problem with one of the cores
!