USB device over current status detected :(

Okay here is the full story:

I plugged in a USB drive when the computer was on. I got a "USB device not recognized" error and right afterwards, my computer froze. I could not even hard reset it. I held down the power switch for 30 seconds and nothing happened so I had to switch off the PSU. From then on in order for the computer to POST at all I needed to switch off the PSU and remove the CMOS battery. Even though I managed to get the computer to POST by removing the CMOS battery, I get a "USB device over current status detected shutting off in 15 seconds" error message every time I got it to POST.

I cannot enter the BIOS either, but I did manage to get into EZ Flash 2, but only with a PS2 keyboard. The computer stopped detecting the USB keyboard.

I have an Asus P5Q Deluxe Motherboard.

PLEASE! SOMEONEPLEASEHELPME!!!!!!!!
T_T
6 answers Last reply
More about device current status detected
  1. USB controller might be damaged. I had a similar problem with my old mother board. I would get frequent BSOD and had bios reset settings back to factory default a lot of the times. Until it finally gave out and wouldn't post any more even with removing the cmos battery.

    Might want to consider getting a new motherboard. :x
  2. So, what I basically did was, I actually managed to fry my mobo with a USB drive??
  3. You HAVE removed the offending USB drive, Right?
  4. Yes it hasn't been plugged into the computer ever since my computer started to act up.
  5. "USB Device over current ststus detected..." same exact issue Asus Essentio Series,
    started having usb issues then just quit getting past the POST. I read that someone actually got to the menu in the BIOS to reset to factory default. I'd like to at least try that. Currently NO USB devices connected and still same issue. removed power and CMOS battery and still no good.

    Can someone tell me where in the BIOS I can find rest to factory default?
  6. The USB port on the front of the tower was broken so the message was correct. I guess moving the computer around shorted the USB port. Unplugged it from the motherboard - problem solved.
Ask a new question

Read More

Asus Computer USB Devices Motherboards