Sign in with
Sign up | Sign in
Your question

Hard Drive not being dedected by BIOS after format.

Last response: in Storage
Share
December 17, 2012 2:17:02 PM

Hi
I have two Seagate 2 TB ST2000DM001
One is already running without any problem have win 7 on it.

On the other, recently bought, i partition it and installed win 7 on my same pc running 1st 2tb hard drive

Then what i done, i booted the pc with my 1st drive and connected the new HD to a SATA to USB converter to see if its works. All 500 GB HD works fine with it but in this larger one, it was showing only 1 partition and was asking for format.

And I did it then came with single partition of 1.81 TB.
Now, when i normally connect that HD to a Mother Board SATA III or II interface it is no longer being detected now

My mobo is ASUS so its freeze on its logo screen and nothing is happening.
But its now working with usb. I deleted the partition still not being detected.

Newest firmware cannot being install because it is freeze in the manufacturer logo screen.
I also tried changing cables and port.

Please help me, i did a really big mistake, what should i do?? I'm worried.
I want this hard drive to be detect by motherboard.

December 17, 2012 4:30:15 PM

My problem is solved.
I again connected that hard drive to usb connector and opened a device manager
there i saw convert to GPT Disk



This was enabled when the drive has no partition. I converted to GPT Disk then shutdown the pc and hooked to the mobo sata interface and viola! It worked! :) 

Started the window and went to the device manager again, it asked for initialize and i selected as MBR.
Repartitioned it and done!

I again tried checking this drive to usb connector, and it again showed as a single partition to format. As I dont wanted to mess up again so i leaved it.

But know why this happens. I am a experienced guy but not too much technically expert.
May any expert tell about this. There is also no information available on google about this.
m
0
l
!