Sign in with
Sign up | Sign in
Your question

SSD WEI 5.9 -> regsitry values already on "0"

Last response: in Storage
Share
December 18, 2012 9:10:51 AM

I'm fairly new in tweaking stuff in my BIOS so please bare with me :) .

My WEI currently gives me a value of 5.9 for my SSD drive. I'm running a crucial m4 SSD 128Gb, in order to increase it"s score I have:

- checked if TRIM is enabled
- checked if the SSD is primary
- disconnected the HDD's (and optical bays)


So I want to switch the SATA mode from IDE to AHCI to see if that gets me where I want to be...

But this is where I'm getting lost, I"ve read that in order to change the SATA mode AFTER a windows installation, you need to change the registry. the exact place for this according to people a lot more knowledgable then me is: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci

But when I check the value, I already have a "0" value and when I check my BIOS I see that IDE is enabled, then how come that my windows is able to boot with a value of "0" (AHCI drivers) but my BIOS is set to boot in IDE? Shouldn't I get a BSOD just as many people get a BSOD when they have their registry value set on "3" and selected AHCI in their BIOS selection?

I'm realy lost here cause I cannot follow the "usual" workaround which is:

1. Set value to "0" in registry
2. Download the AHCI drivers
3. In BIOS set to AHCI -> save and exit
4. Boot into windows
5. Cancel installation wizard
6. Install the drivers from step 2
7. Reboot into windows

If my value is already "0" then how do I go about changing from IDE to AHCI and why do I not get a BSOD due to the fact that IDE has been selected in my BIOS with a value of "0" in my registry?

Thank you all for your kind assistance

December 18, 2012 10:38:06 AM

So changing the value to "0" in your regsitry does not generate the BSOD? Only the changing the BIOS does?
Related resources
Can't find your answer ? Ask !
a c 116 G Storage
December 18, 2012 10:59:34 AM

Which SATA ports are you use? Intel, Marvell? You can't just change Msahci to "0". Double check.

If you use intel, change Msahci or intel ahci to "0" and if you have error message then you follow the microsoft website. If you use the marvell port your SSD is still in IDE mode. You need install the driver first but I will recommend to use intel ports even intel SATAII .
December 18, 2012 8:34:18 PM

I'm using one of the 2 6Gb/s ports on my X79S UP5 mobo (I should have mentioned this in my original post -> sorry for that :)  ). And i'm using intel indeed.


Just to make sure, I did not set the value to "0" it was like that by default. So i'm curious why I did not have a BSOD in my current setup as the value of my registry sits on "0" but the BIOS clearly tells me it's IDE, or how come I'm using IDE when I clearly miss the "3" value in my registry (which is what according to the info i found is the driver value used for IDE).

As I understand a lot of people first need to set their Msahci value from "3" to "0" from IDE to AHCI mine is already on "0" so i'm a bit nervous to follow the guides I found so far.

Thanks for your advise

!