Sign in with
Sign up | Sign in
Your question
Solved

Switching from IDE to AHCI no reg. key

Tags:
  • SSD
  • Storage
Last response: in Storage
Share
December 19, 2012 1:08:18 AM

So my mobo died on me, I switched it and reconnected all my devices out but forgot to set the SATA in the bios from IDE to AHCI on the new mobo. It didn't cause an issue booting to windows or anything but I just realized my error. Now, when I want to switch it to AHCI (as windows was set for before the mobo died) I don't have the msahci registry key to change as all the instructions I've found tell me to do.
Any help would be appreciated.

Edit: in windows 8

More about : switching ide ahci reg key

December 19, 2012 1:52:26 AM

scout_03 said:
page 64 of motherboard user manual ftp://174.142.97.10/manual/Z77%20Extreme4.pdf


oh sorry, that's the motherboard that died on me. I'm running an ASUS P8H77-V LE until my RMA comes back from ASrock.
Also, I know how to set in the motherboard. that's not the problem.
m
0
l
Related resources
a b G Storage
December 21, 2012 1:52:49 AM

so you use the same drive without a reformat for the asus board,you wil have to look at asus bios to set ahci on her.
m
0
l

Best solution

a b G Storage
December 21, 2012 3:01:31 PM

Error message occurs after you change the SATA mode of the boot drive http://support.microsoft.com/kb/922976
Share
December 21, 2012 3:20:52 PM

jemm said:
Error message occurs after you change the SATA mode of the boot drive http://support.microsoft.com/kb/922976


Thank you.
I'm at work so I'll have to give that a shot once I get home. I've been trying the manual regedit method but with out the proper key showing I wasn't sure where to go.
m
0
l
December 25, 2012 11:00:09 PM

jemm said:
Error message occurs after you change the SATA mode of the boot drive http://support.microsoft.com/kb/922976


Ok, well the bad news it that the fix was for windows 7 and wouldn't run on my Windows 8 system.
However, it did lead to me finding this "INACCESSIBLE_BOOT_DEVICE" error message after you install a third-party ATA-miniport driver or change the SATA mode of the boot drive on Windows 8-based computer" This fixed the problem with no issue.

Scenario 1: Third Party ATA Miniport Driver (or in this case AHCI driver)

The following steps will allow the user to properly boot off of a third-party ATA miniport driver. It is assumed that the new driver has already been installed and a reboot of the system is pending:

1.Open an elevated command prompt and set the machine to boot into Safe mode by typing
bcdedit /set {current} safeboot minimal

2.Reboot the machine into Safe mode by typing:
shutdown /r /t 0

Note: In Safe mode all boot-start drivers will be enabled and loaded, including the ATA port driver. Since there is now a miniport installed to use it, the kernel will now make it part of the drivers that are to be loaded on boot and not disable it again.

3.Reset the bcdedit settings to allow the machine to boot into the Normal mode by typing:
bcdedit /deletevalue {current} safeboot

4.Reboot the machine into Normal mode by typing:
shutdown /r /t 0

***4b. The instructions didn't list this step but before allowing windows normal mode to load, enter your bios now and change the SATA from IDE to AHCI, save and exit.***

You should successfully reboot into normal mode using the third-party ATA miniport driver.
m
0
l
December 25, 2012 11:16:16 PM

Best answer selected by ibjeepr.
m
0
l
a b G Storage
December 25, 2012 11:17:10 PM

So, the problem is fixed then?
m
0
l
December 25, 2012 11:18:59 PM

jemm said:
So, the problem is fixed then?

Yeup, running in AHCI mode now. Thanks for the help.
m
0
l
a b G Storage
December 25, 2012 11:37:18 PM

Excellent! :) 
m
0
l
!