Sign in with
Sign up | Sign in
Your question
Closed

XtremeGamer Driver Issue

Last response: in Components
Share
December 2, 2010 4:11:04 AM

I've already done a ton of research on this today, but have found nothing that solves my issue, so I'm turning to a new thread to try to solve my issue.

Today I tried to re-install creative drivers for my XtremeGamer because of some issues I was experiencing that I was just troubleshooting. Initially this turned into a constant BSOD loop and I was able to get into restore and go back to when I had my drivers uninstalled. Here is where the problem came about.

Now whenever I try to install drivers I get the error "You have previously installed drivers without rebooting. Please reboot and try again." I've tried using both CCleaner and Driver Sweeper, making sure all of my Creative programs were uninstalled (some had to be force deleted in the registry with CCleaner...they wouldn't uninstall...such as ALchemy), making sure every Creative file was deleted and even going into regedit and deleting Creative entries. Tried it both in normal and safe mode.

It seems everyone who encountered this error in my research resolved it by manually deleting the registry one way or another. I feel I've cleared every last bit of registry there is to delete, but apparently not?

At one restore point from earlier today, it seems that I have the driver installed, which is odd. When I try to launch the console launcher from Creative so I can enable headphone mode and gamer mode (for better quality) it says no supported device is found. I'm just dumbfounded at what is going on here.

Can anyone give additional input that I haven't tried yet? Seems that a simple reinstall troubleshoot caused my entire day to go away...aye, typical?

More about : xtremegamer driver issue

Best solution

a b \ Driver
December 2, 2010 6:22:11 AM

Typical for creative stuff.... :(  very sad but true none the less, I've tried a dozen creative cards in my system and ultimately came to the conclusion that they work best with XP nothing above that OS is properly supported, always have some issue or the other.

What I can suggest to you is removing your Creative Card from the system, then running all the driver cleaner things for Creative Software. Also checking the registry manually and removing all entries for CTHelper, Creative, Alchemy SoundBlaster, etc etc.... any entry with the name of the programs creative installed even "mixer"..... everything must be deleted....
Do not forget to backup your registry before you fool around with it....

Then reboot and check again if everything is gone, check running tasks for the CTHelper file and you'll know if something is still there.... :) 

After that , try inserting the card in a different slot on the mobo (Compatible Slot) and then boot and see if it detects the new hardware and reinstall the drivers from it's original disc, not the latest downloaded ones......

try this and give a feedback....
Share
December 2, 2010 6:23:57 AM

Alright well, oddly enough, problem fixed. I took a little break from troubleshooting, got some food, came back and decided to run through the rotation another time. Ran driver sweeper and CCleaner, rebooted, and tried to install. It installed just fine...

Rebooted, installed the console, and booted it up as well. Console booted just fine...

Of course it happens after 6 hours of research and trial and error with the same thing I had been doing since stage 1, and right after I post a thread about it, but I can't complain. I guess to make this thread somewhat useful...anyone who comes upon this, just keep running driver sweeper/CCleaner. Seems everyone's solution was that, and eventually, it was mine too. I guess my PC just likes to screw with me the first 20 times I do it.

EDIT: Damn, of course someone responds seconds before I post that it's solved. Thought I had at least not wasted anyone's time, lol, now I feel bad. I tried everything you mentioned, BUT not putting the card in a different slot. Thanks for your input, though, appreciate it :) 

And yeah, I had a similar problem with this card back when I had Vista. Clean install of Win 7 fixed that...that problem was I couldn't update drivers at all...different error, can't remember what it was, doesn't matter anyway. Point is Creative can give you a *** load of pain for good sound. It is a good card, I love the sound, but support/compatibility is just terrible...
Score
0
Related resources
a b \ Driver
December 2, 2010 6:33:02 AM

True, I agree with the sound quality of the card...... still haven't come across one to beat it. But am backing out of any Creative cards just because of these driver & hardware issues......
Am going to try the Xonar or Azuntech brands... they've got amazing reviews and the company is giving a good driver support..... although I think one of them is actually a creative sister concern but yet it's got a better support crew than creative itself.... :) 
But am glad you managed to solve your issue......
and it wasn't a waste of time, I think I'm going to try this in my rig when I get home and give my creative cards another chance... :) 
Score
0
December 2, 2010 6:41:47 AM

Oh, the Auzentech Prelude? A while back when I was having issues with my XtremeGamer I was looking to get that. Did quite a bit of research on it and heard some great things about it.

I remember it being sold out everywhere. Right now it's a deactivated item on newegg:

http://www.newegg.com/Product/Product.aspx?Item=N82E168...

But, yeah, as long as my XtremeGamer is working I will keep it, lol. You can get it for about $30 on eBay and it's amazing sound. Can't beat it, even if I have to pull a few hairs out in the process...if it keeps happening I'll probably eventually trash it.
Score
0
December 2, 2010 6:55:34 AM

Best answer selected by ChicAgoHawk.
Score
0
a b \ Driver
December 2, 2010 11:37:20 AM

This topic has been closed by Mousemonkey
Score
0
!