Sabertooth p67 No Boot

I am building my computer from scratch and am having issues getting it to boot. I have a ASUS Sabertooth P67 REV 3 Intel P67 LGA1155 motherboard with a Intel Core i7-2600K 3.4Ghz Unlocked LGA1155 CPU and a Cooler Master Silent Pro M850 Modular 850W power supply. All I have on the board is the CPU and the RAM, I don't have a video card plugged in.

When I turn the computer on after a couple of seconds the VGA light comes on and stays on and then the boot device led comes on and stays on. I don't hear any beeps at all. Any ideas?
5 answers Last reply
More about sabertooth boot
  1. Welcome to Tom's Forum! :)

    Review in your manual 'Jumper' - use the jumper method to Clear the CMOS {CLRTC} and try again. It should be able to boot without a GPU --> Q - why are you trying to boot without a GPU??
  2. I actually tried this. I'm just trying to get it to boot at all. I initially tried booting with my HDs connected and my GPU connected and it didn't work, so I stripped it down to see what the issue could be.
  3. Q - are both the 24-pin MAIN & 8-pin CPU connected?
  4. Yes, I will double check to make sure the plugs are fully connected, but I am pretty sure they are.
  5. Okay lets assume a short.

    Lazyman's Breadboard -
    * Disconnect ALL Front Panel & USB Headers ; keep only the PWR & Ground <best> short w/wire.
    * Disconnect ALL peripherals including the Keyboard/Mouse
    * (1) Stick of RAM in the second DIMM slot from CPU
    * Unscrew both the MOBO and PCIe screws

    Pull the MOBO away from anything conductive and supported by a towel ; short PWR & Ground to start.

    Q - What HSF? {CPU Fan}
Ask a new question

Read More

Motherboards Sabertooth Boot