Sign in with
Sign up | Sign in
Your question

Creative Alchemy not enabling EAX on X-Fi Fatality.

Last response: in Components
Share
December 2, 2010 9:24:40 AM

I tried to test whether I had EAX to begin with, apparently Guild Wars still doesn't allow me to use EAX even after adding it to Creative Alchemy. It's on Game Mode as well as having EAX enabled(on the Creative Audio Control Board), on a 5.1 system (Z-5500). What am I doing wrong?
December 2, 2010 11:20:44 AM

Does the game have EAX support? If so, what version?
December 2, 2010 3:45:46 PM

gamerk316 said:
Does the game have EAX support? If so, what version?


Not sure. It's a fairly old game and says to support 3D sound /EAX as an option, thing is; other people seem successful in running it. I figure I should be as well.

I'm having a lot of issues with X-Fi: Switching Modes seems to get rid of sound, period. As mentioned above, I'm not sure if EAX even works. I'm using an Optical cable- seems only when I switch to "6 channel Direct" does my back speakers actually function as back speakers, the Optical Stereo X2 seems to just use both front and back instead, so I don't know if I get true 5.1 surround. Even worse is 6 channel direct doesn't seem to work on any games. There's just no sound, even on Game mode. (Assuming switching the mode hasn't canceled all my sound) I'm unable to use any encoding, though I'm not sure if that's because my Control Pod has issues decoding it (It shouldn't, the Z-5500 says it has both Dolby and DTS built in) so I'm not sure what to do. This is my third time reinstalling drivers. It's getting very frustrating. Any help would be very much appreciated.
!