Sign in with
Sign up | Sign in
Your question

Upgrade Intel HD Card for Gateway SX-2850?

Last response: in Graphics & Displays
Share
August 5, 2010 1:05:08 PM

I just bought a Gateway SX-2850. It has 4gb of ram, upgradeable to 8gb, Intel core i3 processor and an Intel HD graphics card and an HD output jack. This is a small form factor PC. I noticed when i play online videos i get intermittent freezes during playback. I already unchecked the enable hardware acceleration box and still getting freezes/delays. I really want to be able to watch HD movies on my LCD TV from my PC. I have an HD cable running from my PC to the TV and it works fine. I just need to get smooth running streaming video! I have 8mbps speed on my internet cable. Is there a better graphics card that will fit in this PC? Will adding more ram help? Thanks.
August 11, 2010 4:41:20 PM

I'm having video and audio issues with my SX-2850. It has already been to their repair depot in TX because the video would not support my middling Samsung DVI monitor...all blue/red screening..something is not driving the monitor sufficiently.

Nor will the audio card support my old Cambridge Soundworks 5.1 Dolby digital system using the onboard Gateway HD audio port....enabled the HD but no luck.

Gateway support is chat-only script-based/non-telephonic...iow mgmt. needs more $$ for jr. at Harvard. I'm getting zero quality from their support.

The Gateway I knew has dissapeared..even the cows went home.

Why do I have to go out and buy upgraded cards to support typical modern devices ?
m
0
l
a b U Graphics card
August 11, 2010 4:53:40 PM

funkymonk said:
I'm having video and audio issues with my SX-2850. It has already been to their repair depot in TX because the video w dont,ould not support my middling Samsung DVI monitor...all blue/red screening..something is not driving the monitor sufficiently.

Nor will the audio card support my old Cambridge Soundworks 5.1 Dolby digital system using the onboard Gateway HD audio port....enabled the HD but no luck.

Gateway support is chat-only script-based/non-telephonic...iow mgmt. needs more $$ for jr. at Harvard. I'm getting zero quality from their support.

The Gateway I knew has dissapeared..even the cows went home.

Why do I have to go out and buy upgraded cards to support typical modern devices ?

Gateway is owned by Acer now. :bounce: 

You really dont, in your case, somethings definitely wrong, bad drivers/Mobo/cord/monitor, but the Intel HD is definitely sufficient for 1080P playback.

Try updating the IGP drivers, and if you're having problems with youtube/hulu HD videos, get the newest version of Adobe Flash.
m
0
l
Related resources
a c 124 U Graphics card
August 11, 2010 5:02:20 PM

If all you want is to play movies, you can get a super cheap card like a GeForce 210 or ATI 4350... these aren't really any good for gaming but for just playing back HD video they're good.

I don't know much about the Intel HD graphics so possibly there's just a driver issue or something. Make sure to update drivers (Driver Detective will let you know if there's anything to update)
m
0
l
December 14, 2010 5:45:22 PM

Hey there. I have the SX2850-01.

I believe your best bet is the ATI HD 5570 (the 210 is too loud from what I hear). I got the Sapphire 100293DP one (from Amazon) without the HDMI port because it was only $70 and still had the DVI port. But you can spend $90 and get HDMI and DVI if you want (Sapphire 100293L from Amazon). One important note is that once you install the low profile bracket, you will lose the VGA port on the card.

I used a Watt meter before and after installing the video card to confirm I wasn't going to blow up the machine (P3 International P4400 Kill A Watt Electricity Usage Monitor, you can get it from Amazon if you want). The meter plugs into the outlet, and the PC plugs into the Watt meter. That way, you get an accurate read on what is really being used.

My tests were trying to push the computer hard with 3DMark06 (repeated back-to-back), Vantage (repeated back-to-back), Starcraft 2 (2+ hours at a time), Force Unleashed 2 (2+ hours at a time), and batch converting several AVCHD HD movie files.

Watt usage was max 87 before I put in the card and around a max of 110 after I put in the card. So nowhere near the 220W capacity.

The maximum Watts the ATI card can pull is almost 43 (even though AMD site says 39, when I called and spoke with them, they said it will vary based on the variations of the card out there). In my tests, the ATI card was only pulling 23, but there is obviously enough headroom if it goes up.

My 3DMark06 (default settings) went from 1741 score to 7545. Frames per second (FPS) on the graphic card tests went from 4-8 range to 20-35 range.

Vantage went from 369 score to 4070. FPS on the graphic card tests went from 0-1 range to 10-11 range.

Game-wise, everything ran perfectly and smoothly and medium settings. I haven't tinkered with the game settings to see how far I can push it, but they look good for now.

I measured the heat/temperatures using CUID's HWMonitor app, but I really don't know what those numbers mean (i.e., I don't know how much heat is too much). But the computer didn't crash or freeze even once, and placing my hand near the case didn't feel that hot. When you install the card, it does appear as though there are a bunch of air holes punched in the case right above where the ATI card sits, but then there is the outer case right on top. So, in theory, should be able to take the very top part of the case off to provide more air to the ATI card (or maybe just cut out a piece of the top case right above the ATI's fan). I have not done this yet, but it's an option.

The ATI card ships with a bracket installed that is too big, which you need to remove, and replace with a smaller "low profile" bracket (it was included with mine). This involves removing the two screws flanking the DVI port as well as a single screw on the board. Once you've removed those, you only need to pull the VGA ribbon pins off the card (just gently pull it out). Fit the low bracket plate on, put back the two screws flanking the DVI port and put the card in the computer. It was a tight fit for me. I stole the wi-fi's final top screw to fully seat the ATI card. Plugging a DVI cable from the ATI to the monitor (and nothing in the VGA) worked without any adjustment to BIOS. So I did not have to disable the integrated video card.

I found it rather difficult to gather information on this, so here is what I found for your reference:

Thailand Gateway page showing a version of SX2840-002T with i5 and ATI 5570 in it:
http://th.gateway.com/products/catalog.html?cat=desktop

A review that says the SX2840 pulls 76.14 Watts per hour in "load mode."
http://blog.itechtalk.com/2010/gateway-sx2840-01-review...

A site that lists SX2850-33 pulling 81.13 average Watts per hour in "load mode." This isn't far off from my personal tests showing 87 Watts max.
http://reviews.cnet.com/desktops/gateway-sx2850-33-comp...

A review that specifically suggests putting ATI 5570 into the SX2840:
http://computershopper.com/desktops/reviews/gateway-sx2...

A guy who put an ATI 5570 in his SX2840:
http://www.avsforum.com/avs-vb/showthread.php?p=1856590...

Hope that helps!
m
0
l
!