Sign in with
Sign up | Sign in
Your question

A gamer running out of options

Last response: in Graphics & Displays
Share
August 5, 2010 7:30:29 PM

I am really starting to get annoyed with flight simulator x now.

the problem is the fps which is like 8 at med settings and get this.... my computer is a

quad core q8400
ati 4870 512mb
3gb 800mhz ram
seagate 500gb raid hardrive
msi p7n sli motherboard
and all driver are up to date =(

this is realy annoying me because all my other games run smooth and nice but as soon as i run fsx its not smooth at all its all jitty and weird and the other thing is when i turn off everything in the game setting the fps bumps up to a measly 56fps.... now is that ok for that system or is there somthing wrong because ive tried everything i can online and offline to fix it and no luck so far.

my main suspects are as follows

vsync is on and i cant find a way to turn it and get this, its off on my ati ccc....
i have a virus but i dont think viruses could effect one game...
or something relating to driver overlaying..

please i need a good answer and one that will help or fix this annoying flaw.

thank you

More about : gamer running options

August 5, 2010 8:33:43 PM

From all accounts I've heard, MS Flight simulator X is very CPU intensive, and due to years of modifying the existing program, is not effeciently coded.

What resolution do you run it at?
August 5, 2010 9:27:29 PM

firstly, what is your RAM setup?

That is a dual channel board... so if you have 2x1.5gb you're fine (although I've never seen a 1.5gb ram stick for sale aanywhere)
*If you are using 3sticks of 1gb, you're actually hurting yourself as they will run in single channel

Your computer specs are still pretty good... and that is still a really good video card. You may want to pickup a good heatsink/fan and overclock the CPU - that might be your best bet as bumping it up to 3.1 or 3.2 will show big results in FSx.

Related resources
August 5, 2010 9:35:36 PM

You have an awesome computer for FSX.. try opening the task manager and tell it to stop food supply to all the cpu intensive background apps.. FSX needs CPU!
August 5, 2010 10:00:43 PM

there was a command i had to use for Sim City 4 while running it in Win 7 (It says vista, but the article was written before Windows 7) that would run that app before all of the others...

Everything worked great after that, maybe it could be an easy fix like that?

EDIT: Here's the actual link:

http://www.simtropolis.com/omnibus/index.cfm/Main.SimCi...

August 5, 2010 10:04:00 PM

Yeah it's the CPU, probably could try OCing it and setting the program to top priority in task manager.
August 6, 2010 4:02:55 AM

If I recall, there is an option to use directx 10 which makes a lot of difference. It may be that a patch for that is required for it.
You might get better advice on one of the FSX forums.
August 6, 2010 10:06:51 AM

to all replies, i am running a 18.5 inch widescreen moniter at 1366:768

and ill give the overclock and the program a go to see any difference.

thanks guys ;) 
!