USB driver error on new motherboard

Hi,

I just installed a new biostar tp67xe motherboard and even after installing the newest chipset drivers from biostar and the new usb 3.0 drivers none of my usb ports are working. i get power on my usb mouse, but i am unable to use it or any other usb device. Neither the front or rear panel usb ports work.

I've verified that the usb is enabled in the bios.

The Windows 7 device manager shows errors for the usb 2.0 and 3.0 controllers (code 37). When i try to uninstall and reinstall the 3.0 drivers i get an error popup as well that the driver did not install correctly.

Is this an issue with the new motherboard, or just a software issue that i need to resolve? The only other idea i have is to flash the bios, but i can't use the biostar bios utility as it doesn't respond to keyboard commands, there is no ps2 port for a mouse, and the usb mouse isn't working. i also cannot flash from a usb drive.
10 answers Last reply
More about driver error motherboard
  1. Well there's two versions of your MOBO, so I looked at the TP67XE Ver. 5.1. Right off the bat the USB 2.0 drivers aren't for Windows 7. Windows 7 has USB 2.0 native, but does require the USB 3.0 drivers. The 'power' and 'function' are from separate circuitry and indicate nothing.

    edit: Try the Clear CMOS procedure: CMOS button or CMOS jumper ; read manual. Pulling the battery isn't the same. Your CMOS 'may' be corrupted.

    edit: Sometimes the Cases's USB ports are 'bad' {shorted}; try unplugging ALL of the USB Headers.

    You can attempt to roll back the USB drivers and/or disable the USB 3.0 drivers + reboot to see if that corrects the problem long enough for a BIOS Flash.

    Q - are there any other {? or !} listed in the Device Manager?
    Q - what drivers did you install and I assume you got them from -> http://www.biostar.com.tw/app/en/mb/driver.php?S_ID=527
    Q - what changes did you make in the BIOS?
    Q - what Windows 7 32 or 64 bit?
  2. I have version 5.1.

    I'm at work now, so i'll try unplugging the usb header and resetting the CMOS as soon as i get home.

    In the meantime.

    win 7 64bit

    there were 4 "!" in the device manager if i remember correctly.
    -PCIe controller (can't remember exactly)
    -usb 2.0
    -usb 2.0
    -usb 3.0

    Changes to the BIOS: i tried turning the usb ports off and back on, then i reset to default when that didn't work, other than that i changed the delay at the splash screen to give me more time to enter bios.

    The drivers i installed were for the tp67xe 5.1 from biostar-usa.com
  3. The PCIe can be from your NIC or GPU - sometimes an Audio driver; assuming no other PCIe Cards are installed besides the GPU. If something is shorting it can wreak havoc.

    For 'Now' simply use the UEFI/BIOS Defaults; less variables by default all should work.

    Let me know later. Good Luck! :)
  4. OK, i unplugged the front panel usb header and cleared the CMOS with the jumper. The usb mouse is still not working.

    The specific errors in the win 7 device manager are as follows:

    PCI Simple communications controller (code 28) no driver installed.
    Intel(R)6 Series/c200 series chipset family usb enhanced host controller - 1C26 (code 37) cannot initialize the driver
    Intel(R)6 Series/c200 series chipset family usb enhanced host controller - 1C2D (code 37) cannot initialize the driver
    Renesas Electronics USB 3.0 Host Controller (code 37) cannot initialize the driver
  5. Is that a fresh install or you ported your old installation to the new mobo?
  6. It's a ported installation to new mobo.
  7. Assuming that you 'installed' the drivers then Manually select the driver(s); use the Update Driver and {Advanced} option 'Have Disk' the source can either be the CD/DVD or from the drivers in the System or Temp that the extracted installers created {when in doubt use the MOBO's CD/DVD. More than likely the PCIe 'is' the USB 3.0 HUB - do it last...its probably going to be installed once the USB 3 is installed.
  8. Thanks for all the help. A clean install of win 7 seems to have resolved everything.
  9. Yeah, that to...glad to hear :)
  10. I had a similar issue this week and I didn't have to do a clean install. I also have a z68xp-ud4 mobo from gigabyte REV.1.0 This thing has been the biggest piece of junk but overclocks like a boss. I have read about issues pertaining to this board so after a year of WTF moments I am moving on to the ASUS SABERTOOTH Z77.

    What happened was I updated the Intel 6 series/c200 chipset family to the latest version for 6 series boards and it it caused a corruption. I had to reinstall the gigabyte version to get the host controller back to version 9.20.1021 but the package installer is 9.2.0.1030.

    I haven't had problems downloading from Intel for updates but in this case i needed to stay with Gigabytes installer package to get the bus controllers to work for the USB 2.0 I have an Etron USB 3.0 host controller but it didn't make a difference with that installed to the mainboard not functioning properly from the wrong driver package. Sometimes we have to stay with the OEM drivers.
Ask a new question

Read More

Motherboards USB