X58 sabertooth cpu led

Hello,
just put a new pc together x58 sabertooth put everything together but it doesnt want boot, the cpu led light is coming on. any ideas
9 answers Last reply
More about sabertooth
  1. the cpu hasn't been properly seated. That LED is a warning...did you also check the manual tat came with your mobo?
  2. i reseated the cpu and its as it stated in manual gold arrow and the 2 indents. still no joy

    id
  3. can we have the full specs of your rig in question?

    possible causes:
    1.Dead CPU
    2.Dead Motherboard
    3.CPU not getting any or enough power.
    4.Bad PSU

    take a look at this: http://www.tomshardware.com/forum/261145-31-perform-steps-posting-boot-video-problems
  4. parts
    Motherboard X58 sabertooth
    PSU OCZ750
    Graphics GTX 460
    Harddrive estern Digital WD20EARS 2TB Hard Drive SATAII 64MB Cache
    processor intel i7 950
    Memory 6GB DDR3 1600MHz 3x 240pin DIM corsair


    When i take the cpu out in the socket there is one socket that feels differen to the rest of the pins so i think it is that causing the prolem
  5. Thas it, the bent pin is the issue! Replace the mobo and on that note, check the CPU and see if the pins/contacts have any damage. At times like this, both cpu and mobo could take damage.
  6. I am sorry to hear about the bent pin/ pins. I hope you fix it without adding more money to your build.
  7. the cpu looks ok fingers xd
  8. hello, im the exact problem, i read in a forum that its cause of a dead battery of the mobo, replace it !!!!!
  9. Quote:
    hello, im the exact problem, i read in a forum that its cause of a dead battery of the mobo, replace it !!!!!


    Exactly what happened, you are a genius bro, 1000 thanks for you... :D :D :D
Ask a new question

Read More

CPUs Sabertooth LED Monitor