Sign in with
Sign up | Sign in
Your question
Closed

Screen flicker when opening/closing Flash video.

Last response: in Graphics & Displays
Share
August 8, 2010 6:42:37 AM

Recently I have noticed that when I open or close a Flash video, either my primary or secondary monitor will have a weird flicker effect. It's not that the display itself is flickering on and off, it's just that for a split second or so the screen will become distorted. It's sort of like a Picasso painting, in that the parts of the screen seem to be just moved around randomly. As I said, this happens for a second, and then the screen returns to normal. It seems to switch between my primary monitor and secondary monitor at random though. It doesn't seem to matter which monitor has the video on it.

I'm not sure if this is a Flash issue or a problem with my graphics card. I suspect that it's a Flash issue though, because if I play a Flash video in a Windows virtual machine this problem doesn't happen. I have tried reinstalling Flash and updating my graphics drivers, but the problem persists. I'm not sure what else to do at this point. I am mainly concerned that this could be a symptom of my graphics card going bad.

Does anyone have any ideas? I would at least like to rule out my graphics card as the issue.

Other info that may help diagnosing the problem:
I am running Windows 7 64-bit and my graphics card is a Sapphire Radeon HD 5770. My main display is a HF237 (Hannspree 23.7" LCD monitor) and my secondary display is an old 19" LCD security monitor. The resolution for my main display is 1920x1080 and the resolution for my secondary display is 1024x768. This Flash problem is the only graphics related problem that I am having. All of my video games (many of which are pretty high-end), run just fine and don't cause the screen to flicker when I start or close them.
September 14, 2010 12:47:55 AM

Having the same issue with similar specs (5770, vista 64bit ultimate, 8 gigs ram). Happends when opening some flash videos and some .mov or .mkv. Seems like it started happening after last driver update but rolling back to 1.5 ati catalyst was no help.

Any ideas?
Score
0
September 20, 2010 10:08:47 PM

Seems like a ATI problem. My 4890, 5830, and 5850 all have the same flicker. Its hard finding any info about it. I reran windows and used older drivers seems to have fixed it for my HPC. AMD's new drivers seem to have caused more problems then they fixed. :??: 
Score
0
Related resources
December 22, 2010 10:36:23 PM

Try right clicking on any flash video. Click on settings (i.e. Adobe Flash Player settings) and uncheck 'enable hardware acceleration'.

This has fixed the problem for me. I'm running 2x5870s with the latest drivers.
Score
0
March 4, 2011 5:48:23 AM

I just came across this thread wondering about the issue as well. What works better for me is to disable Enforce Smooth Video Playback in your Video settings of Catalyst Control Center. I also have the quality settings set to apply to internet video.

If anyone can submit bug reports on Enforce Smooth Video Playback causing the Picasso flickering, please do. This bug still exists as of today.
Score
0
March 14, 2011 2:20:26 PM

I have been having this problem as well and I found a YouTube video with someone demonstrating the issue. Looking through the comments, many people recommend disabling ATI Overdrive, the overclocking utility. I have had this problem for months and after disabling that, the problem is now gone.

Link to YouTube video: http://www.youtube.com/watch?v=L9PMqcFBdO4

Also worth noting: I had the issue with two ATI 5000 series cards, a 5850 and a 5870. Both gave the issues with overdrive enabled and both worked just fine when disabled.

Edit: It fixed the problem for a few minutes but now it is back... I thought it was fixed...
Score
0
March 21, 2011 12:02:40 AM

orcslayermack said:
I have been having this problem as well and I found a YouTube video with someone demonstrating the issue. Looking through the comments, many people recommend disabling ATI Overdrive, the overclocking utility. I have had this problem for months and after disabling that, the problem is now gone.

Link to YouTube video: http://www.youtube.com/watch?v=L9PMqcFBdO4

Also worth noting: I had the issue with two ATI 5000 series cards, a 5850 and a 5870. Both gave the issues with overdrive enabled and both worked just fine when disabled.

Edit: It fixed the problem for a few minutes but now it is back... I thought it was fixed...

That is the exact issue that I am having. I disabled Overdrive, but it did not help. I am at least glad to see that I am not the only person who is having this issue. Thanks for the video, now I have a link to send when people ask me to describe the problem.
Score
0
March 21, 2011 1:08:45 AM

Slayer706 said:
That is the exact issue that I am having. I disabled Overdrive, but it did not help. I am at least glad to see that I am not the only person who is having this issue. Thanks for the video, now I have a link to send when people ask me to describe the problem.



I've been doing more testing with this problem and I found that I only have issues when I have more than one monitor plugged in. I have an asus 21.5 inch 1080p monitor as well as a Dell 1024x768 and a 1080p 42 inch LG TV. I only get the issue when I have the Dell monitor plugged in. I have tried only having my ASUS and Dell plugged in trying both active and passive adapters on the dell. When I just have my 2x 1080p monitors plugged in I have no problems.

Could this issue be a result of multiple monitor resolutions in conjunction with this card/flash?
Score
0
May 11, 2011 6:45:57 PM

davidstrongarm said:
Try right clicking on any flash video. Click on settings (i.e. Adobe Flash Player settings) and uncheck 'enable hardware acceleration'.

This has fixed the problem for me. I'm running 2x5870s with the latest drivers.



thx, worked like a charm.
Score
0
a c 271 U Graphics card
a b C Monitor
May 11, 2011 6:52:51 PM

This topic has been closed by Mousemonkey
Score
0
!