Cant format 3tb Sata3 in Sata2 port past 764mb

Hey guys

I have two pcs. One running WHSv1 and one running Windows 8.

WHS (32bit) - sees 3tb in Bios but the O/S won't format past 764gb (note: thats NOT the 32bit limit which is 2.1gb(?))

Windows 8 (64bit)- SSD (working fine), 3tb in SATA 3 slot (working fine) BUT, if i put ANOTHER 3tb in a SATA 2 slot, it won't see passed the 764gb limit either!? (Again, BIOS see's it as 3tb)

So, this seems to suggest that my Western Digital Caviar GREENs cannot be used in SATA 2 slots as the evidence says it's nothing to do with 32/64bit (as it works in SATA 3 slot) or the O/S (same error on both)... is this correct?

Any ideas why I might be seeing this strange limit and how to get around it???
1 answer Last reply
More about cant format sata3 sata2 port past 764mb
  1. Sorry, forgot to say that in BOTH systems I can convert it to GPT and it makes no difference, still get stuck at 764.
Ask a new question

Read More

Hard Drives SATA Windows 8 Format Storage