Sign in with
Sign up | Sign in
Your question

Asus Rampage II no post/no error beeps

Last response: in Motherboards
Share
August 7, 2011 6:20:50 PM

I think I might have a toasted motherboard due to a possible power surge. I say surge because my LCD Poster is garbled and missing parts of the characters.

I have attempted to reset the bios (reset button on back). And when I power up, I can hear the drives - but no output to the monitor. I disconnected the mouse and keyboard, shut down, and restarted - NO ERROR BEEPS.
I pulled the Vid Card out and restarted - still no error beeps.

As far as I know, as long and the drives are getting juice, the board should be as well. There are plenty of lights on the board that seem fine. But the no error messages make me think that it's the board and not just a toasted card.

After pulling the power, and resetting the bios via the back button, I was once able to get the bios to post. But not again.

Anybody have experiences with the error message beeps on this motherboard?
August 7, 2011 9:58:32 PM

This may not be a solution but i've been experiencing a similar issue though mine might be to do with not overclocking my RAM properly. Anyway my computer all of a sudden got really unstable - restarting itself and shutting down randomly, memtest86+ found 400 thousand errors on the ram so that partly reinforces my opinion that it still could be the RAM causing the problem. Managed to get it to boot once after resetting the CMOS but now won't boot at all even if I press CMOS. LCD poster still displays "power off" msg after attempting to turn on the pc and lights all work. I've tried each stick of ram and turning it on too, also with no ram in and i get the same results. Going to try new ram this week.
m
0
l
!