Sign in with
Sign up | Sign in
Your question

Asus UL80Jt Not playing like it use to. HELP!!!!!!!!!!!!!!

Last response: in CPUs
Share
December 10, 2010 6:55:16 PM

Hello

I bought this laptop about 5 months ago from Bestbuy. When i bought it it ran Flawlessly
with World of Warcraft. I could run the game in ultra with a few setting decreased putting
the FPS at around 50-60. Well ever since i bought the laptop its been going down hill. Besides
A ton of other issues, the main one i want to fix is the Processor load. When im playing WoW I
will run chrome/Pandora.com in the background. This usually over loads the CPU and makes it more
frequently run at 100%, but when i don't have Chrome open it runs at 60-100%. But it will still over
load it to 100%, but less frequently. I really cant figure out what it is. When this processor load
was actually Noticeable was when Cataclysm 4.0.1 was released. It was fine but i posted in the Blizz forums
that i could see the water detail on max level. I was told to update all my drivers. Being unexperienced i think i did something wrong. But idk. Please can someone help me, lead the way i need to go. Ask me to post DX or something.

Thanks,
William


P.S. If you need me to post info off my computer that might seem difficult to get tell me step by step on how to get this information.

More about : asus ul80jt playing

December 10, 2010 7:24:48 PM

/bump
m
0
l
December 10, 2010 8:59:20 PM

Bump
m
0
l
December 11, 2010 6:09:01 AM

bump
m
0
l
Related resources
!