Sign in with
Sign up | Sign in
Your question

Intel 330 120gb + Asus P5n32-E + Toolbox = fail!

Last response: in Storage
Share
December 28, 2012 1:49:31 PM

First of all I would like to say that I'm mega impressed with the Intel 330. I'm on a tight budget and picked it up for £76.

It's made my system significantly faster, the intel data migration tool is excellent for a bit of free software. Copied everything over and checked the partitions and they are correctly aligned (read lots of stuff online that suggested they would not be but with my Windows 7 build I had no problems at all) Confirmed that TRIM was active and turned off defrag so basically all happy.... however...

I then tried to install the SSD toolbox and everything went horribly wrong. It detected my SSD but threw up and error suggesting that the system needed to be re-scanned and then the program just shut itself down. I can't get it to work. I am not in RAID mode in the BIOS and the board is a bit old so it does not have AHCI settings in the BIOS however when I check computer management it suggests that an AHCI driver is loaded. The HDD appears as a SCSI device.

Can anyone shed any light on why this might not be working!? Help much appreciated.
a b å Intel
a c 124 G Storage
December 28, 2012 2:19:17 PM

The intel toolbox don't run in IDE mode, so you download the AS SSD http://download.techworld.com/3248894/as-ssd-benchmark-... and put it in the USB, run the program but don't click the "star" buttom, in the window if you see upper left side (like intel 300i firmware name, iaStora mean you are in AHCI, if you see pciide mean you are in IDE mode).

If you are AHCI mode and download the CCleaner or Advanced SystemCare from cnet.com http://download.cnet.com/windows/
Clean up the invalid registry entries then try to reinstall the intel toolbox.

If you are in IDE mode, go to http://support.microsoft.com/kb/922976 and change to AHCI mode. reinstall the toolbox.
a b å Intel
a c 167 G Storage
December 28, 2012 2:29:05 PM

If your motherboard is so old that it does not support AHCI, then you are not going to get trim commands passed through to the ssd.
At one time, the SSD toolbox only ran in IDE mode, so you might try to hunt down such a copy.
There should be a utility that you can run from time to time to free up nand blocks and accomplish what trim does.
Trim is very helpful in managing updates and improving performance.
But... as you have found out, you still get a big boost from the SSD without it.
You will really have no big issue up to the point where the SSD is approaching full.
I might leave it be until you get a more modern motherboard.
Related resources
a b å Intel
a c 124 G Storage
December 28, 2012 3:06:47 PM

Yes, geofelt is right. Your MB only has the RAID or IDE mode from NVIDIA, and you may try to install the toolbox under the RAID mode. If you still can't, just let leave it alone in RAID mode that is better than IDE mode without the toolbox.

Also you can use the free version SSDlife to monitor the SSD http://ssd-life.com/
December 28, 2012 10:22:16 PM

Ah, so what you are suggesting is that even though if I confirm the TRIM command is turned on in windows it doesn't actually mean the TRIM command is working? Because I sort of don't care too much about the toolbox. I would like it to work obviously, however I'm going to be upgrading my mobo and processor soon so as long as TRIM is working then I don't really mind too much in the short term.
a b å Intel
a c 124 G Storage
December 29, 2012 4:14:29 AM

Because TRIM command allows an operating system (win7/8) to inform a solid-state drive (SSD) which blocks of data are no longer considered in use and can be wiped internally.

If you use win7 or win8 then it will work either IDE or RAID mode.

And now TRIM will work on RAID mode but only for the Z77 or P68 MB when you use intel driver.
December 29, 2012 10:17:51 PM

Eureka!

I've got it working and I sort of don't know how. Here is what I did, I turned RAID on... and the computer wouldn't boot. Then I actually configured RAID properly so happy days it booted. I thought I've cracked it! Opened SSD toolbox and instead of saying it could not recognise the drive it said it was not an Intel drive so basically told me to get lost. So back to the drawing board. Installed nVidia RAID drivers from the website and tried again and no go. Also the computer was now running like a dog. So.... got upset and decided to change it all back. Un-installed the nVidia drivers and rebooted the machine, went into BIOS and turned RAID off. Went back into windows and it re-installed the drive again. Opened the SSD toolbox... not sure why just for one last try. The damn thing only now works! I mean WTF?

So I'm deleriously happy everything is now working and the machine is running the best it ever has. The only thing I can guess has happened is that I read another post on Tom's Hardware from someone with a similar problem who suggested going into device manager, into IDE ATA/ATAPI controllers and if the drive appeared as an nVidia device change it so that it now appeared as a 'Standard Dual Channel PCI IDE Controller'. Now I didn't check this before changing the RAID settings, I'm guessing that when I changed it RAID that it changed this driver, then when I changed back it stayed as the above. Anyway below is an Image of my Device Manager in the vain hope this may help someone as I have been messing with this for hours!

!