Sign in with
Sign up | Sign in
Your question

Seagate drive not working with ASRock motherboard/Windows 8

December 28, 2012 9:29:19 PM

I recently upgraded my motherboard and OS to an ASRock Z77 Extreme 4 and Windows 8. When doing that, I installed the OS from scratch on a new drive and brought over all my previous SATA drives.

One of those previous drives simply will not work properly on the new system and I'm trying to figure out why?

The drive is a Seagate 1TB model number ST31000340AS and it will not work normally when connected to a motherboard SATA port. This is what I've observed:

* This drive worked perfectly fine on my previous Gigabit motherboard.
* When connected to the new configuration (ASRock motherboard SATA port), the drive does not function normally in Windows. I can navigate the folder hierarchy but I can't view any files and I can't write to it and it doesn't show in Disk Management, but it does show as a drive letter.
* If I attach the drive via USB using a SATA to USB adapter the drive works perfectly fine (albeit slower and external to the case) so I think the drive itself and drive formatting is working fine.
* The motherboard has both SATA controllers set to AHCI (not IDE).
* I have six other drives that are working fine (one SSD, one DVD drive and four SATA hard drives)
* When attaching to a SATA port on the motherboard, the drive is recognized by the BIOS.
* The drive shows up in the Windows Device Manager
* The drive does not show up in the Windows Disk Management list at all.
* The drive does show up as a drive with a letter assigned in the My Computer view.
* I've tried the drive with a problem in both SATA controllers (one is SATA2 capable, one is SATA3 capable)
* I've tried the drive in a SATA port and with a SATA cable that works for other drives to rule out either of those.
* When the troubled drive is connected to the SATA port, the computer takes forever to shut-down. Remove the drive and the computer shuts-down quickly. Something appears to be having trouble communicating with this drive.
* When connected via USB (the only way the drive works normally), I've both reformatted and repartitioned the drive to try to rule out anything with that. I can't repartition when connected via SATA because the drive doesn't show in Disk Management. If I try to reformat when connected via SATA, nothing happens when I select Format in the menu. It just does nothing - no errors, no UI, nothing.

Any ideas why Windows won't work normally with this drive?
!