Sign in with
Sign up | Sign in
Your question

XP not recognizing IDE Primary Slave

Last response: in Storage
Share
December 30, 2012 6:01:48 PM

I am adding a used HDD to my current desktop. The old drive comes from an unused computer that I am stripping for usable parts, so there is no failure of components involved in either computer. I am running XP home on my computer, but the OS will not recognize there is a slave device attached to the Primary IDE at all. Here's my setup:

Main Board: MSI K7N2 MS-6570
OS: Windows XP Home
IDE Primary Master: WD 320GB HDD
IDE Primary Slave: WD 160GB HDD
IDE Secondary Master: DVD/CD-RW drive
IDE Secondary Slave: CD-RW drive

All four drives are fully recognized in the BIOS in their proper configuration (see the photo link for screenshots), I have an 80 wire cable attached to both sets of drives (Primary and Secondary) which I have swapped out for new cables during troubleshooting, and I have ensured the jumpers on all drives are set properly. Windows Disk Management does not recognize the Primary Slave at all therefore it is unable to assign a drive letter.

I know for a fact the second HDD is working properly, I had switched the IDE cables at the main board so the DVD/CD drives were on the Primary IDE Channel and the HDDs were on the Secondary IDE channel. After starting up the computer, both HDDs were recognized by XP and I was able to remove the partitions from the slave drive and reformat it in NTFS. However, now the slave DVD drive was not recognized (even in Microsoft Disk Management). I have switched the IDE cables back so the HDDs are on Primary and DVD/CDs are on Secondary.

See these photos in photobucket for my configurations: http://s1251.photobucket.com/albums/hh560/postal302/Com...

So the main problem here is XP will not recognize a slave on the Primary IDE channel regardless of what the device is. I know for a fact it is not a faulty device/cable issue, not a configuration issue (jumpers or cable order), or any hardware issue, but the problem is with XP.
December 31, 2012 11:28:07 PM

So I hate it and love it all at the same time when it turns out to be a simple fix. As our turns out, in the device manager under the IDE controllers you have the option to select auto detect or no device for each device on each IDE channel. My primary IDE controller for the slave device (disc 1) was set to none. Simply changing it to auto detect and restarting the computer made the primary IDE slave available. Consider this issue solved!
m
0
l
!