Solved

SSD Slow Performance

Hello all,

I recently purchased a Sandisk Extreme 240GB SSD. The advertised speeds are 550 MB/s read and 520 MB/s write, but I seem to only be getting 393 read and 405 write. Can anyone explain to me the issue? The drive is connected to the sata 3 port and is on a 6gb/s cable. I have an ASRock extreme4 motherboard, 3570k, 16gb of RAM, and no HDD connected at the current time. I also have the ASmedia SATA 3 driver installed, and have tried to install Intel RST, but don't know if it improves performance as i can't get it to start. Everytime I install a version above 11.2, I get a crash with an error message. I can get it working on 11.2, but the drive isn't even recognized in the program. I guess my questions are: Why are my speeds slow, how do I improve them, am I missing any drivers (I have chipset drivers installed), and is RST necessary for better performance?
4 answers Last reply Best Answer
More about slow performance
  1. Best answer
    You need connect the SSD to the SATAIII_0 or SATAIII_1(from intel) not the one (SATAIII_A0 or SATAIII_A1) you put the SSD. All the third party SATAIII drivers don't work well like the intel SATAIII.

    As long as you re connect the SSD to the SATAIII_0 or SATAIII_1 then you will be fine.
  2. Figured it out. Sorry for the double post, i had it plugged into the marvell port instead of the intel. Read and Write speeds are now each above advertised!! Couldn't be happier.
  3. cin19 said:
    You need connect the SSD to the SATAIII_0 or SATAIII_1(from intel) not the one (SATAIII_A0 or SATAIII_A1) you put the SSD. All the third party SATAIII drivers don't work well like the intel SATAIII.

    As long as you re connect the SSD to the SATAIII_0 or SATAIII_1 then you will be fine.


    Ah, haha it seems as I found out the problem as you were posting. Thank you anyways. The difference is huge!
  4. Best answer selected by susejchristo.
Ask a new question

Read More

SSD Performance Storage