Sign in with
Sign up | Sign in
Your question
Solved

Trouble getting ASUS AI Suite II to install on Sabertooth 990FX

Last response: in Motherboards
Share
a b V Motherboard
August 13, 2011 3:56:05 AM

I have an ASUS Sabertooth 990FX motherboard and I cannot get the AI Suite II software that is included with it to install. Has anyone else who has this Mobo had this problem and how did you fix it?

What I have checked so far.

Tried installing AI Suite II from Mobo support CD. Install program starts and and UAC asks for permission to run four different programs. After answering yes to all the Install seems to continue but nothing ever happens.

Tried downloading AI Suite II from ASUS website. Same result as before.

Tried redownloading AI Suite II from ASUS website. Same result as before.

Went to ASUS Motherboard website under Sabertooth 990FX Mobo and looked for similar problems. Sure enough, this is a known problem. The suggestions that supposedly fixed it suggested that there were 3 ASUS services that should be running to get AI Suite II to install. The instructions told how to check for the services but did not tell what the names of those services were. Anyone able to tell me what ASUS services should be running? I found 3 services and one of them was not started so I went ahead and started it but nothing changed. I think that the other two services were related to another ASUS Utility called Disk Unlocker.

Uninstalled Disk Unlocker. Same result as before. The Only Asus Service currently runnins called ASUS HM Com Service and it is started.

Reinstalled Sabertooth 990FX Chipset drivers. Same result as before.

Best solution

December 13, 2011 10:43:41 PM

JKatwyopc said:
I have an ASUS Sabertooth 990FX motherboard and I cannot get the AI Suite II software that is included with it to install. Has anyone else who has this Mobo had this problem and how did you fix it?

What I have checked so far.

Tried installing AI Suite II from Mobo support CD. Install program starts and and UAC asks for permission to run four different programs. After answering yes to all the Install seems to continue but nothing ever happens.

Tried downloading AI Suite II from ASUS website. Same result as before.

Tried redownloading AI Suite II from ASUS website. Same result as before.

Went to ASUS Motherboard website under Sabertooth 990FX Mobo and looked for similar problems. Sure enough, this is a known problem. The suggestions that supposedly fixed it suggested that there were 3 ASUS services that should be running to get AI Suite II to install. The instructions told how to check for the services but did not tell what the names of those services were. Anyone able to tell me what ASUS services should be running? I found 3 services and one of them was not started so I went ahead and started it but nothing changed. I think that the other two services were related to another ASUS Utility called Disk Unlocker.

Uninstalled Disk Unlocker. Same result as before. The Only Asus Service currently runnins called ASUS HM Com Service and it is started.

Reinstalled Sabertooth 990FX Chipset drivers. Same result as before.


I know this is a little late, but I just got the ASUS MoBo and tried to install the AI Suite II and it would not install. After searching many sites, I came up with this patch (http://dlcdnet.com/pub/ASUS/mb/LGA1155/AI_Suite_II_Patc...). Unzip the patch into the same folder as AI Suite II, run the patch then run the AI Suite II setup. It worked for me.
Share
a b V Motherboard
December 14, 2011 3:37:04 PM

Actually, I finally fixed it. It has something to do with the way that it starts up several ASUS system processes at the same time. I never did get it to install until I re-installed windows again. Then it went without a hitch.

:o  Hmm, rereading what I posted before, I can think of one difference between the first time when nothing worked and the second when it did. The first time I had the Sabertooth 990FX Chipset drivers installed from the CD/website, I am pretty sure that I didn't install them before installing AISuite II after re-installing Windows at that time.

However, I just recently reinstalled windows again but this time AISuite II would not install (I did, however, install the chip set drivers from the ASUS website first). I tried the patch that you suggested and it didn't work for me. After looking on the ASUS website forums I found one post that said to try installing the USB 3.0 Boost package first. That package uses a very limited version of the AISuite II to install the updated USB3.0 drivers which does not have any problems with getting the processes to run. After Installing the USB 3.0 Boost program then the full version of AISuite II installs just fine.

I have seen several posts on the ASUS website forums that suggest a couple of other methods but one of these two seems to be the most consistent.
m
0
l
Related resources
a b V Motherboard
December 25, 2011 4:43:09 PM

Best answer selected by JKatwyopc.
m
0
l
September 14, 2012 11:38:00 PM

Hi man, I just saw reading your post, that you have 16gb 2133 installed on sabertooth mobo, which speed do they work without overclocking? Any SPD reducing when populating 4 dimms? i was thinking in corsair sets 4x4GB 1600, or crucial ballistix 4x8GB14900. What results do you get ?
m
0
l
!