Sign in with
Sign up | Sign in
Your question

Hard Disk not detected, PLEASE HELP!

Last response: in Storage
Share
January 1, 2013 2:53:12 AM

Hey everyone,
I'm having a problem with my computer. Please note I do not know much about computers and any help will be appreciated.
So what has been going on is that I bought a EVGA GTX 680. Before installing it, everything was working fine. I turned off my computer, unplugged all the wires, and replaced the GPU. My other graphics card was a 560.
After I installed the 680, I plugged everything back in and started my computer.
Everything started up fine, my motherboard light turned on, all the fans turned on, everything seemed to work.
Until it goes to one screen where it says Disk Information: No Hard Disk Detected! Press SPACE to continue. After that, it goes into this 2.2tb infinity thing. I have a MSi X58A-GD45 motherboard by the way, and I'm pretty sure the infinity thing comes with the motherboard. Anyways, after loading up, it says Please select the boot device: CD/DVD : ATAPI iHAS124 C
it is the only option available so I press enter and it says "No bootable device, Press any key to go back..." Now I know I have to put a CD in that the computer can boot on, like a Windows 7 CD or something like that. But my computer already has Windows 7 Home Premium installed. I've looked around and people have been saying to go into the BIOS and change the boot sequence or something. Now I don't know what the Hard disk should show up as, but I'm sure the BIOS doesn't detect it. All I see in default order is:
USB: Generic- SD/MMC
USB: Generic- Compact
USB: Generic- SM/xD-Picture
USB: Generic- MS/MS-Pro
CD/DVD: PS-ATAPI iHAS124 C
2.2TB Infinity

Also, I don't know if this'll help but in the Integrated Peripherals in the BIOS it goes like this:
USB Controller - Enabled
USB Device Legacy Support - Enabled
Onboard LAN Controller - Enabled
LAN Option ROM - Disabled
Onboard IEEE1394 Controller - Enabled
Onboard E-SATA Controller Mode - IDE
SATA 6GB/s Controller Mode - IDE
Onboard USB 3.0 Controller - Enabled
USB 3.0 Controller Mode - Enabled
HD Audio Controller - Enabled
PCI IDE BusMaster - Enabled
On-Chip SATA Controller - Enabled
RAID Mode - IDE
COM Port 1 - 3F8/IRQ4

I spent all day trying to figure out what to do, and nothing seemed to work. I tried reinstalling my 560 and same thing happened, No Hard Disk Detected. Please help, because this is really annoying. I can't even get into my login screen anymore and I would much like to do so...everything seemed to work yesterday, but all this started to happen today, after I installed my new GPU. I didn't fiddle around with any wires except the two 6-pin connectors for the 680. I'm pretty sure all the Hard Drive wires are all connected to the motherboard correctly, because I have checked multiple times. Long story short, is my Hard Disk done for? Do I need to get it replaced or what other solutions are there. Like I said, much help is much appreciated. Thanks in advance!

More about : hard disk detected

a b G Storage
January 1, 2013 3:05:04 AM

Try different SATA ports on the motherboard and check back in the BIOS.
m
0
l
January 1, 2013 3:06:57 AM

Where would the SATA ports be located...
by the way Happy New Year!
m
0
l
Related resources
a b G Storage
January 1, 2013 3:10:19 AM

Same to you. Just follow the thin wire from your HDD to the mother board. There will be another one just like it for the CD\DVD drive. They are usually located around the edge and close to where the drive bays are
m
0
l
January 1, 2013 3:32:24 AM

oh thank you!
I found that one of the SATA wires that hooked up the actual hard drive was loose.
Tightened that up and everything worked fine...looks like all the researching was a little useless.
After that I reset the CMOS thingy and everything worked great!
Thanks for your help!
m
0
l
a b G Storage
January 1, 2013 3:34:08 AM

Glad to help you with your "loose ends" :D  Happy New Year and computing!
m
0
l
!