Micro-freeze/Hiccups in games on new build

Hello, I've recently built a new computer and have been tearing my hair out trying to fix this issue. What happens is during games the game will freeze for around .5 - 2 seconds, becoming unresponsive though the cursor still moves and sound and music still play. The HDD access LED is solid during this time. It will occur at specific times, say in Starcraft II just as a building completes construction, though not every time. The game runs silky-smooth the entire time otherwise, at 60 fps regardless of what else is going on.

I have three hard drives in the computer, an SSD as the system disk with Windows 7 64-bit installed on it while the majority of games are installed on a RAID0 of two Western Digital 1.5TB Caviar Blacks. I am nearly positive it has something to do with the RAID, as another game that was giving me a lot of trouble, League of Legends (would hang for 1 second during large fights, enough to entirely mess up my game), became perfectly fine after I installed it on the SSD instead of the disk array.

I have tried many things and installed all possible drivers associated with my motherboard and SATA/RAID controllers several times and nothing has entirely rid me of the problem. It was much, much worse before I disabled "Onboard SATA Controller" in the BIOS, but the problem still persists, just less consistently. Before I did that, every single time I destroyed a building in Starcraft II, or every time someone talked in Recettear, it would hang briefly. Now it is not as consistent, though it still seems that specific events trigger it.

I've contacted Western Digital about it, but they just told me to run their disk-checking program and to RMA if it turned up bad. Ran the long and short test twice and everything was fine. Outside of games the RAID performs admirably, large files read and write without a hitch. Of course, it is not the system drive, so naturally Windows performance is not likely to be affected.

This has been fairly frustrating to me, as everything else about the computer is perfectly fine, and I've built several computers for friends which have not had this issue (though none of them had RAIDs), and this is my first time building one for myself. I appreciate any advice you can offer!

I'll list a few of my components which may be the issue, as I'm still not 100% sure it's just the HDDs. If you need any more info I'd be glad to provide.

Motherboard: ASUS Rampage III Formula
SSD: Crucial RealSSD C300 64GB
HDDs: Western Digital Caviar Black WD1501FASS 1.5TB 7200 RPM x2
RAM: G.SKILL PI 6GB (3 x 2GB) 240-Pin DDR3 1600, currently clocked at 1440 MHz, 6-8-6-20 timings
CPU: Intel Core i7-950 @ 4.15 GHz (problem occurs at standard clocks as well)
GPU: EVGA GeForce GTX 470 (Fermi) 1280MB x2 (though this occurred before I got the second card as well)
15 answers Last reply
More about micro freeze hiccups games build
  1. Since you are describing classis disk access delays, are you using Win 7 default SATA/RAID drivers or did you install the latest drivers from Intel?
  2. Yeah, I've got the latest Intel drivers I could find. Believe they were published in 3/2010. They came on the disk with the motherboard too, since it's a fairly new mobo.

    Specifically, this: http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=18859&ProdId=3061&lang=eng
  3. So which SATA ports are your HDDs and SDD plugged in to? Are you using the Intel, JMicro, or Marvell connections (all use different drivers unless I am mistaken).


    Your specs say:

    Intel ICH10R controller
    6 xSATA 3.0 Gb/s ports
    Intel Matrix Storage Technology Support RAID 0,1,5,10
    JMicron® JMB363 PATA and SATA controller
    2 xExternal SATA 3.0 Gb/s port (SATA On-the-Go)
    Marvell® 9128 PCIe SATA 6Gb/s controller
    2 xSATA 6.0 Gb/s ports
  4. The two WD HDDs are on the 6 SATA ports, ports 0 and 1 specifically. The SSD is on the SATA 6.0 Gb/s, since it is a 6.0 Gb/s drive. I've got the latest drivers for all of them installed, and the RAID shows up in the device manager view by connection under the Intel SATA/RAID controller.
  5. To clarify, you disabled the JMicron ports, then, correct? Leaving only the Intel and Marvell controllers enabled.

    Just trying to isolate the problem.
  6. Yeah, that seems to be what I disabled. The JMicron no longer shows up as initializing during boot and the drivers don't show up in the device manager like they did before. Not sure why disabling it led to improvements but it was definitely noticeable.

    I'm more than happy to provide what info I can, I appreciate the help!
  7. In your device manager, for the HDDs, under advanced options, is write caching enabled (I am asking this from memory, sorry if I am not spot on where to look).
  8. It is enabled indeed.
  9. What anti-virus/anti-malware software are you using? Also, are you using the Intel RAID Manager application?
  10. Microsoft Security Essentials, and yes. It shows the RAID and the two drives the comprise it.
  11. Check out the readme for your controller/software:

    http://downloadmirror.intel.com/18859/eng/Readme.txt

    Can you verify (section 6, I think) that all is installed properly?
  12. Yep, that all looks good.
  13. This is certainly a tough one. Are there any obvious settings in the RAID manager (matrix I assume) that will let you tweak the drive settings?

    I am also wondering what would happen if you moved your SSD to one of the Intel SATA ports.
  14. There aren't very many settings in the RAID manager to tweak the drive settings, regrettably. Mostly just creating new volumes and the like. And disabling the drive cache :/

    I've just now tried several things involving the SATA ports - unplugging the eSATA front port, moving the RAID drives to ports 2 and 3, putting the SSD on the Intel SATA ports, all of which result in the same behavior.
  15. I'm bumping this relatively old thread because I'm suffering the very same problem and I'd like to know if a solution was found.

    Like the OP, I narrowed the problem down to the HDDs, since video and audio drivers were all up to date and disabling the sound engine for some games didn't stop the micro-freezing from happening.

    I'm not using a RAID setup, but I do have two HDDs running in SATA. My Intel AHCI controller driver is up to date and everything should be working without a hitch, yet I'm suffering from the exact symptoms stated in the OP while gaming. Mass Effect occasionally freezes when selecting a dialog option and when it tries to load certain sound effects during/after combat, ME2 has delayed audio in all cutscenes and sometimes hiccups during gameplay, Starcraft 2 and Guild Wars both suffer from irregular micro-freezing. Winamp rarely, but sometimes freezes while playing music.

    The OS is installed on one HDD while my music library and games are installed on the other. As a troubleshooting step, I did attempt to run some of the games off of the first HDD, but the problem persisted.

    Specs:
    Acer Aspite 7745G Notebook
    Windows 7 64-bit Home Edition
    Intel Core i5 460M
    8GB DDR3 RAM
    ATI Mobility Radeon HD 5650
    Western Digital WD5000BETV 500GB x2

    Of interest is what PC Wizard tells me: The ACHI controller reports only having 4 ports, and the 2nd HDD does not show up plugged to any of those four ports (two being empty; the system HDD and my BD-ROM takes up the first pair). The Intel RST app tells me the 2nd HDD is plugged in on Port 5. I'm no computer expert but I'm pretty sure there's something wrong with that.
Ask a new question

Read More

New Build Games Systems