Graphics Card Problem

Hey Guys,

I'm having some problems with my new ATI HD5750 1GB GDDR5 Graphics Card.When i play games i.e Gta 4,Dirt 2 and also HD Video's i get grey stripes and vertical lines.But when i installed my graphics card for the first time i could play the games without any trouble then slowly after playing for a couple of hours the things started happening.
Then i tought it could be the drivers then i upgraded my catalyst 10.2 drivers to 10.7(i uninstalled my 10.2 drivers i even used driversweeper for this and then i upgraded to 10.7)but then i still got the grey stripes and vertical lines.The graphics card is connected good on my mobo i have even put the 1x6 pin connector but i suspect that my power supply isn't good enough because it is a 300w atx power supply and i have a lot of hardware maybe that could be it.

My System Specs:
Intel Q8300 2.5GHZ Core2Quad
4x2gig's of samsung ram
1TB Hard Drive
LigthScribe DVD Drive
And also the ATI HD5750 Graphics Card

Please Guys I really need some help!!!!!!!
3 answers Last reply
More about graphics card problem
  1. Hello and welcome to the forums
    I think your PSU is causing this problem because AMD recommends a 450W+ PSU for HD 5750
    http://www.amd.com/us/products/desktop/graphics/ati-radeon-hd-5000/hd-5750/Pages/ati-radeon-hd-5750-system-requirements.aspx
  2. Agreed. PSU is probably almost certainly inadequate. But that's not the kind of problem usually caused by inadequate power.

    Try installing the card into another computer and see what happens.
  3. I had this happen on my 5870 a few times, the only common factor was that it happened while i was trying to overclock the balls off it and the heat was higher than normal... Monitor your heat before and while the issue happens, try to see if you're producing too much heat...
Ask a new question

Read More

Graphics Cards Drivers Games Graphics