Sign in with
Sign up | Sign in
Your question

Computer shows solid amber light

Last response: in Motherboards
Share
August 15, 2011 5:56:06 PM

Hello, So I was on my computer last night and i've been looking to upgrade the CPU and so i found out that I need to upgrade my BIOS to make it work. I have a Dell Dimension E521. Fortunatly dell has a bios upgrade that is an executable from inside windows after you download the upgrade. Unfortuantly when I ran it, it wouldn't respond and thus didn't work. The executable was stuck on the part of erasing the current BIOS. So that freaked me out a bit but the computer still worked fine after that. I left it on overnight so it could copy some files from an external over to an internal. When I woke up, the moniter was in power save mode, the front of the computer had this amber light, and the fan was still going. I thought it just went to sleep so i pressed a button on the keyboard and it didn't wake up. I've been looking around on the internets and they suggest it could be the power supply but I'm afraid the BIOS update messed it all up. What makes me think it could be either of this is that before I started it the first before i even got the bios executable, it said LOW POWER and KEYBOARD FALIURE! Now i didn't have the keyboard plugged in and so i think maybe the power supply is bad, or the BIOS battery is dead. There is this Amber LED lit up inside the computer too. Did i just break the motherboard? None of the keyboard lights blink on then off when i turn the computer on, same with everything else. Its like it doesn't even know they are there.

PLEASE SOMEBODY HELP ME!!!
a c 108 V Motherboard
August 15, 2011 11:04:30 PM

This could be purely coincidental; meaning your CR2032 battery has failed. Although they should last at least a couple of years, batteries are imperfect. It is also possible the PSU is failing. First I would remove the CMOS battery for about a minute and then reinsert it. If that doesn't help, remove all of the RAM from the mobo and reattempt to boot. If you have a mobo speaker installed, you should hear a series of beeps indicating an error was detected with RAM. If this happens, then chances are the mobo is fine.

To test the PSU, you'll need to either use a multimeter, preferably a digital one; or swap the PSU with another known-good-working PSU (as in it was just used to turn on a different computer, successfully).
m
0
l
August 15, 2011 11:18:23 PM

I just tried that, nothing changed.
m
0
l
Related resources
a c 108 V Motherboard
August 15, 2011 11:59:24 PM

After reading your other post, I did some searching as well. It would seem that BIOS writer for the E521 mobo did not make a DOS-based version. Also, you're not the only one to have the BIOS update fail on you. According to all I've read so far, your mobo has been rendered useless to the BIOS chip not flashing properly.

In this thread, a user found the replacement mobo for $79, though this post was a couple of years or so ago, so I can't comment on availability or reliability of the info, but like all others who share your experience, a replacement mobo is the only remedy.

http://en.community.dell.com/support-forums/desktop/f/3...
m
0
l
August 16, 2011 12:12:51 AM

Yea, i'm trying to use some old old old old bios for the e521 that i foudn that is DOS. I'll let you know how it goes. I'm fine with buying a new motherboard, i just don't want to. I'll just upgrade to an AM3 socket board if thats what it comes too. But i'll post how it goes
m
0
l
!