Sign in with
Sign up | Sign in
Your question

My brand new XFX 5870 won't output video

Last response: in Graphics & Displays
Share
August 13, 2010 10:29:19 PM

Hi!
I recieved my new computer today and everything worked fine, but when I got home from work I tried to run World of Warcraft, and all of a sudden my XFX 5870 stops outputting any video. I've tried turning off the PSU for a while, unplugging my USB-devices and connecting my 40" Samsung LCD TV with a HDMI-DVI cable. The TV won't show any video either. I'm not so sure that my keyboard and mouse were being powered up either. But as I mentioned I unplugged the USB-devices, and it's a few hours ago, so I can't say for sure.

Here are my hardware (I'm running Windows 7, 64bit Home Premium by the way):
- Chieftec Super Series 750W
- ASUS Crosshair IV Formula
- AMD Phenom II X6 1090T Black Edition
- CoolIT Systems ECO A.L.C. CPU Cooler
- Kingston DDR3 HyperX 1333MHz 2GB CL7-7-7-20 (x2)
- XFX Radeon HD 5870 1GB (My Samsung 22" LCD Monitor is connected with a VGA to DVI adapter)
- Sony NEC Optiarc AD-5240S
- Samsung SpinPoint F3 1TB SATA2 32MB 7200RPM (x2)
- Corsair SSD Performance P64

I have no idea what to do.
Will try to provide more information on request.
August 13, 2010 11:02:54 PM

I managed to boot the pc with one memory module only, but I couldn't replicate the result with neither one or two.
August 31, 2010 4:43:27 PM

Try setting you ram to 1066 in the bios, then put in both sticks and see what happens. If you get video with that, than you have a ram problem. I had the same issue with kingston 1333 ram, had to down clock it to 1066 to get ti work properly. I ended up getting this ram instead.... http://www.newegg.com/Product/Product.aspx?Item=N82E168... put the ram to 1600 no probs at all, ran it at 1066 no probs, 1333 machine would not boot at all. It appears to be some sort of problem with the way 1333 runs for some reason. BTW I am using an ASRock 890FX Deluxe3 mobo.
!