Solved

New System hangs with "loading OS..."

Hi,

I built a new system today but I am having troubles installing Windows 7 on it.

The main problem was that the windows installer couldn't find the hard disk, but after some BIOS tweaking, the system now hangs on "loading operating system..." (and I can't even get into the BIOS again).

Some more details on the system:

Motherboard: Gigabyte GA-870A-UD3

CPU: AMD Phenom II X6 1055T (with factory fan)
RAM: Kingston 2 x 2G DDR3 1333 (KVR1333D3N9K2/4G)
GPU: His Radeon HD 5770
Case : CoolerMaster Gladiator 600 (with 500W PSU)

HDD: Western Digital Green Caviar 500 GB SATA
CD/DVD+RW: Samsung SATA 22x

(No Floppy disk drive)
(Also attached a logitech wireless keyboard via USB)


After a couple of boot attempts (which all ended with the "Loading Operating System..." message) I changed the boot order (pressing F12 at the splash screen) in order to install windows 7 (Home Premium 64) from the DVD.
It was quite slow and eventually (after eula) it complained that no hard disks were found.

I rebooted, went to the BIOS, looking for the devices, and both were listed as IDE slave (which was initially puzzling for me).

I went to the manual of the mother board, and there is a section about RAID which is not very clear (i.e. it's not clear if it is relevant, since I have only one disk). Anyway it said to set the sata ports as "raid" (instead of ide), which I did. But then the DVD was no longer visible (at least, it didn't even attempt to boot from it).

After various unsuccessful trials, I plugged the DVD cable into the sata 5 port (the bios said that ports 4/5 type was IDE). This time the system booted up from the DVD, but still didn't see the hard disk.

With some googling (and reading through the mobo manual again) I found that some drivers are needed. So I inserted the cd-rom I got with the mobo and pointed to the suggested directory (for raid). The window installer found and installed the driver, but still failed to recognize any hard disks.

So I went back to the Bios and changed the Sata type to AHCI. (the available drivers on the CD are either for raid or ahci). But again it didn't work (windows installs the driver but still doesn't find any drive).

Back to the bios again, I tried the " Load Fail-Safe Defaults" (at some point I also plugged the HD cable in the sata 4 port, don't remember if before or after this last change).

Anyway, what happens now at boot is this:

The system starts (with fans spinning etc.) there is one beep on the mini speaker, the gigabyte splash screen flashes for one sec and the "Loading Operating System..." message appears on the screen (with the cursor flashing below it).
This happens very quickly and any keys (del, f12, tab, ...) are ignored.

Also, Ctrl-Alt-Del doesn't help and I have to turn off the power.

Any idea on what could be going on ?

(I also removed one of the ram modules, but with no change in behavior).


Thanks a lot,


Fabio
8 answers Last reply Best Answer
More about system hangs loading
  1. Hmm, you are using IDE? Yeah well if you have 2 hard drives with IDE you need to set a slave and a master.
  2. I have one Hard Disk and one CD/DVD, both SATA (No actual IDE devices / cables).
  3. Best answer
    To get out of your current fix you will need to clear the CMOS memory. Read your manual on how to do this, MAKE SURE that you disconnect the mains cable before clearing the CMOS.
  4. I cleared the CMOS memory, now I can access the BIOS again.
    I can boot from DVD, the windows 7 installation starts, but it still fails to find the hard disk.

    My current configuration is this:

    the Hard Disk's sata cable is plugged on port 2 and it is seen by the bios as follows:

    > IDE Channel 1 Master [WDC WD5000AADS-00M2B]

    when I select it I see:

    IDE HDD Auto-Detection [Press Enter]

    IDE Channel 1 Master [Auto]
    Access Mode [Auto]

    Capacity 500 GB


    None of these options have any effect (when I press enter for auto detect it just detects it)
    the other two options can be set to either "Auto" or "None"


    When I go to the "Integrated Peripherals" page the settings are as follows:

    OnChip SATA Controller [Enabled]
    OnChip SATA Type [Native IDE]
    x OnChip SATA Port 4/5 Type [IDE] (this option is gray)
    x OnChip SATA3.0 Support [Enabled] (this option is gray)
    Onboard GSATA/IDE Ctrl [Enabled]
    Onboard GSATA/IDE Mode [IDE]
    Onboard ESATA controller [Enabled]
    Onboard ESATA Mode [IDE]

    ... and then other options for LAN/Audio/USB etc.


    Any ideas on what could be going on ? Do I need a special driver for this hard disk ?
    The motherboard came with a CD with drivers, but they are only for RAID and AHCI modes (which I both tried without success).

    Thanks again,

    Fabio
  5. You shouldn’t need a driver if you are in IDE mode. ESATA and GSATA (purple connectors) can both be disabled in the BIOS. Make sure that you have the hard drive and the CD drive in the orange connectors.
  6. Hmmm... not sure I follow here.
    There are 6 blue SATA-3 ports (connected to the SB850 controller) and 2 white, right-angled GSATA2 ports (connected to the Gigabyte Sata2 controller).
    See here: http://www.hardwarecanucks.com/forum/hardware-canucks-reviews/33418-gigabyte-870a-ud3-am3-motherboard-review-5.html

    I tried (almost) all combinations of ports and bios settings with no success.

    I've seen lots of forums messages (here and in other sites) about people having similar problems (the installer of windows 7 premium 64 doesn't find the sata hard-disk) but no actual solutions (most answers require a windows installation already available on the machine, but I have a brand new pc and a macbookpro, from which I am writing now).

    On the other hand, I was able to install ubuntu 10 on it.
    I will try next to install win 7 as a virtual machine via virtual box...
  7. After installing ubuntu, and successfully installing win7 as a virtual machine on top of it, I tried to install win7 from scratch.
    This time the installer found the linux partitions!

    I deleted them (from the installer itself) and proceed with the installation on the disk.

    I still don't understand what the "right" way would be.
    Apparently the hard disk has to be already formatted (in some way) in order to be found by the window installer.

    It is not clear yet how to format it (without having to install another OS first).

    Anyway, windows is now installing fine.
  8. Best answer selected by fabio_zxcv.
Ask a new question

Read More

New Build Systems