Sign in with
Sign up | Sign in
Your question
Solved

Do Gfx cards switch to X4 instead of X16 if theres not enought power

Last response: in Graphics & Displays
Share
August 14, 2010 10:07:38 PM

do Gfx cards switch to pci-e X4 instead of pci-e X16 if theres not enought power



i have a xfx 4770....running on a antec 380watt power supply thats 3 years old

i have a asus m4a785-m board

it was fine until i look at gpu-z and it said it was running at X8 so i took out the card and put it back in and now its running at X4 and i tried everything i could to get it to x16 or even x8 and it wont

so could this card switch to x4 because it does'nt have enough power
or is it something else


a c 376 U Graphics card
August 14, 2010 10:09:24 PM

Nah, the power has nothing to do with that and your PSU should be fine for the card.
Most likely you just need to reseat the card. It could take a few tries.
m
0
l
a c 195 U Graphics card
August 14, 2010 10:10:31 PM

The number of lanes it has available has no effect on its power consumption, even a PCI-E 1x slot provides 75W of power, and the 4770 doesnt need much power. I would check your BIOS settings to see if something there is slowing you down.
m
0
l
Related resources
Can't find your answer ? Ask !
a c 216 U Graphics card
August 14, 2010 10:24:05 PM

I've had this issue due to poor seating of the card. I've had to blow air through the slot before as well. It's probably due to poor contact with the slot.
m
0
l
August 15, 2010 2:35:06 AM

jyjjy said:
Nah, the power has nothing to do with that and your PSU should be fine for the card.
Most likely you just need to reseat the card. It could take a few tries.


reseted the gfx card 8 times
i reseted my pci-e 1 card (dial-up modem)
jump my bios 3 times
clean out the gfx card slot 3 times
i reseated the pci-e connector on the card
took out the card let windows run on just the onboard video then put the card back in
redid the graphics card driver
redid the mobo bios
tried the speed on pci-e to 101 mhz and 105mhz
try to up the pci-e to 120MHZ max
take out the mobo and put it back in
took out ram cards to help see if voltage is a issue
install mobo chipset drivers
redid windows 7
up the chipset voltage tried 1.31000V
unplug everything from my mobo,power supply except whats needed

and nouthing work
m
0
l

Best solution

a c 376 U Graphics card
August 15, 2010 3:58:28 AM

Well, that is certainly thorough. The only thing I can think of is perhaps getting a can of compressed air and seeing if it can help clean out the port for a better connection.
The good news though is that your PCIE port is 2.0 and a 2.0 slot even at x4 shouldn't really limit an HD4770. So your problem isn't really much of a problem. If the problem persists and some day you upgrade your video card than it may be an issue but still not all that much of one. Here is an article on PCIE scaling where they test using the HD5870 which is over twice as powerful as your card;
http://www.techpowerup.com/reviews/AMD/HD_5870_PCI-Expr...
Even on that card the difference between x16 and x4 was only 5% overall.
Share
August 15, 2010 5:16:22 AM

jyjjy said:
Well, that is certainly thorough. The only thing I can think of is perhaps getting a can of compressed air and seeing if it can help clean out the port for a better connection.
The good news though is that your PCIE port is 2.0 and a 2.0 slot even at x4 shouldn't really limit an HD4770. So your problem isn't really much of a problem. If the problem persists and some day you upgrade your video card than it may be an issue but still not all that much of one. Here is an article on PCIE scaling where they test using the HD5870 which is over twice as powerful as your card;
http://www.techpowerup.com/reviews/AMD/HD_5870_PCI-Expr...
Even on that card the difference between x16 and x4 was only 5% overall.



hi i feel a little dumb i jump my bios again and this time left all my settings on default and its at x8 i thank its my bios they might have to update it sence i have the most upto date version i know x8 isnt that bad of a perfromance drop but x4 was i was getting black screens on gta 4 some times i just wish i knew why its doing this i might want to upgrade my card in 1 or 2 years
m
0
l
August 15, 2010 5:23:11 AM

Best answer selected by jdwii.
m
0
l
!