Sign in with
Sign up | Sign in
Your question
Solved

Amd Phenom 2 940 Blackedition Heatsink

Last response: in CPUs
Share
December 21, 2010 6:47:08 PM

Hello, I am looking for either a free or very cheap or pay only shipping for heatsink for this processor. The one I have now is not working correctly, but letting it idle at 70C and it shutdown when I try and do anything.

I never receved a heatsink with this processor when i purchased it.

I have reapplied the Arctic silver 5 3 times, a drop a little larger than a piece of rice and spread it with a credit card.

I really need a heatsink, I am trying to do my school work and my comp is useless.

It took me over 7 months to save up for this processor on Newegg.

Thank you.
a b à CPUs
December 21, 2010 7:41:53 PM

donald7777 said:
Hello, I am looking for either a free or very cheap or pay only shipping for heatsink for this processor. The one I have now is not working correctly, but letting it idle at 70C and it shutdown when I try and do anything.

I have reapplied the Arctic silver 5 3 times, a drop a little larger than a piece of rice and spread it with a credit card.

I really need a heatsink, I am trying to do my school work and my comp is useless.

It took me over 7 months to save up for this processor on Newegg.

Thank you.



You should check that the Heat sink is securly attached, also does the heat sink fan spin?
Related resources
a b à CPUs
December 21, 2010 7:49:43 PM

The standard heatsink with that cpu should cool the processor just fine if it is installed correctly.

Either the fan isn't spinning, you have absolutely no airflow in your case, or the heatsink is not attached to the cpu correctly.
December 21, 2010 11:19:46 PM

I never recived a heatsink with the processor. It was a deal on new egg for this years black friday for a processor only.
December 21, 2010 11:21:51 PM

geekapproved said:
The standard heatsink with that cpu should cool the processor just fine if it is installed correctly.

Either the fan isn't spinning, you have absolutely no airflow in your case, or the heatsink is not attached to the cpu correctly.


Fan is spinning with the exhaust to the rear case fans.

I even attached a 120mm dc fan that runs at 3800 rpm on the heatsink.


The heasink has 4 heatpipes that are burningly hot (found out the hardway) but the fins are cold.
a b à CPUs
December 21, 2010 11:56:51 PM

Well something is definitely wrong. If you are certain of your installation and Thermal paste then you should get something else right away as you've surmised.



That is a 125W CPU so a $10 HSF is not likely to do you much good. I recommend you look at the Arctic cooler 7 pro at the minimum, but in your shoes I would get this:
http://www.newegg.com/Product/Product.aspx?Item=N82E168...

It is an excellent cooler, especially for $30. I hope you will give this serious consideration.

One more thought, is the X4 940 on your motherboard's approved list?
December 22, 2010 12:24:58 AM

+1 to the Cooler Master 212+

I have a Phenom II X4 955 Black Edition with a 3.6 GHz overclock and when I had the stock fan that comes with that cooler installed, it was cooling it perfectly fine.
December 22, 2010 1:36:51 AM

Unoffically the mobo supports it asus is to lazy to update their supported cpu list.

I already talked to their support and they assured me it would work.
December 22, 2010 1:51:14 AM

Ill see if i know anyone that can loan/ give me the $30 for the cooler. Thats a lot of money so when i can get it i will post the results. thank you.

Best solution

a b à CPUs
December 22, 2010 2:13:40 AM
Share

You should probably check ebay for the box cooler that comes with maybe the 955, 965, or 1055t +. They are all more than capable of cooling your cpu at stock settings, and will be dirt cheap!

a quick search shows this listing, for 15.00 and free shipping:
http://cgi.ebay.com/AMD-Original-Copper-Heatsink-Fan-AM...

good luck!
a b à CPUs
December 22, 2010 1:09:15 PM

donald7777 said:
I never recived a heatsink with the processor. It was a deal on new egg for this years black friday for a processor only.


Ok maybe it would have been helpful to mention that in your post. LOL
December 22, 2010 5:06:17 PM

btw, what temps are you getting?.
I have same cpu with Arctic Freezer Pro heatsink. Temps are around 36degC.

That heatsink you have should cool it unless maybe the tubes have broke their seal and leaked it's contents. weird.

December 22, 2010 9:31:28 PM

hemmi said:
btw, what temps are you getting?.
I have same cpu with Arctic Freezer Pro heatsink. Temps are around 36degC.

That heatsink you have should cool it unless maybe the tubes have broke their seal and leaked it's contents. weird.



It idles around 70C overheats and shutdown at 120C with load.
December 22, 2010 9:32:20 PM

Ok i had my computer on its side and the heatsink seems to work better.

It idles around 70C still but only gets up to 90C with load.
December 22, 2010 11:04:38 PM

I have the stock heatsink/fan that came with my amd phenom II x4 970 (i got that cooler master and it works great) idk if it would fit but i'd guess it would since they're both am3. send me a pm if you're sure the after-market cooler you got is the problem and you're still looking for a stock one

it sounds like maybe you're heatsink isn't making a good connection though if putting your comp on its side works better. not sure why tho, maybe that brand/model just sucks. i'm sure its been said in this thread but double check that everything is secured tightly and all the components are in the right place. originally i installed the back plate backwards on the back of the mobo cause it goes one way for intel and the other way for amd.
December 30, 2010 3:22:45 AM

Best answer selected by donald7777.
!