Sign in with
Sign up | Sign in
Your question
Solved

Fail Memtest but Pass Prime95?

Last response: in Motherboards
Share
August 18, 2011 6:13:59 PM

I am trying to track down the source of an intermittent fault.

Symptoms:

a) intermittent BSOD (even with just a browser running);
b) once froze while in BIOS; and
c) occasional failure to POST (three long beeps) but hitting reset usually gets past this.

System:

Win 7/64 Home Prem / GA-890GA-UD3H / AMD 1090T / 4x 4 GB G. Skill F3-10666CL9D-8GBXL / Corsair AX750 Pro Series Gold

Tests:

EasyTune6 / CPU-Z / Memtest86 / Prime95

Have progressively stripped away all peripherals except: 1 DVD / 1 HDD / 1 RAM (4 GB) - using only onboard video.
All voltages normal per specs. Memory at 1.5V and 9-9-9-24.
BIOS is Award ver. FF which is most recent non-beta. Most drivers up to date.
ALL memory has failed memtest, usually at Test 7 - Blockmove. At that point the program will stop due to unexpected interrupt after spewing red error list for a few minutes.
System will boot in to Win 7 and will run Prime95 successfully for hours ?! (It has yet to BSOD while doing this.)

Thoughts:

a) It is unlikely to be the PSU. It is new and high-end;
b) It is unlikely to be the CPU. Prime95 would crash if that was the case, right?; and
c) Is it the memory? What are the odds I would get _4_ bad sticks from _2_ different packages?

I'm guessing then that the mobo is a problem. But would it make the memory fail the memtest? And if so, why does Prime95 run so happily?

Anyone have any ideas/guidance?
a b V Motherboard
August 19, 2011 5:49:06 AM

It could well be the motherboard, especially if you are using the same slot for testing all the time. If you're using slot A2, try B2. It could be the CPU as the memory controller is in the CPU – but very unlikely. It almost must be memory-related. Which Prime95 test are you running?
m
0
l
August 19, 2011 1:47:16 PM

I was running 'blend'. I tried upping the RAM voltage incrementally. Always, the Prime95 worked and Memtest86 failed at Blockmove. Really odd.

Note that the memory is cited by G Skill as being 'optimized for Intel'. I discovered that is a hot topic for debate :)  Anyways, I am going to pick up some Corsair memory that is compatible with the board (according to Corsair) and see what happens. That should settle the mobo question.
m
0
l
Related resources
August 19, 2011 1:56:46 PM

Oh, I did try varying the slots. No change in behaviour.
m
0
l
August 19, 2011 5:03:45 PM

New memory, same Memtest results. So mobo or CPU.
m
0
l
a b V Motherboard
August 19, 2011 9:57:34 PM

Are you overclocking at all?

I would suspect motherboard, but that is because CPU problems are rare.
m
0
l
August 21, 2011 8:11:04 PM

UPDATE: Still does not pass Memtest86 BUT have had it run for eight hours with the following: Prime95 (blended test), Firefox, Word, and VMWare (Machine with Win2000 running Matlab doing data processing). Did not crash. I'm at a loss.

I not so secretly think its because I have a replacement mobo (GA-990FX) with 16 GB of new memory (Corsair Vengeance 1600LP) standing by to go in as soon as the machine fails ... so naturally it will never fail again :-) I'll update here if anything develops.
m
0
l
a c 716 V Motherboard
August 21, 2011 8:31:51 PM

Oddly, the blend test typically fails if you don't also add the Command Rate, at least on DDR3 1600 MHz or faster.

To the equation, add the Command Rate and obviously set the RAM Freq/CAS manually.
F3-10666CL9D-8GBXL
CAS 9-9-9-24-2T (CAS-TRCD-TRP-TRAS-CMD) ; often in BIOS it's Command Rate {2, 2T, or 2N} all the same value.

The only guaranteed Ripjaws X DDR3 1333 MHz in 4x4GB is the F3-10666CL9Q-16GBXL set.

Next, if that fails and I read 4x4GB raise both the DRAM Voltage -> 1.55~1.60v and on AMD the CPU NB Voltage 1.25v~1.30v. The reason for the variance is 10 identical systems respond to 10 different settings.

Q - What tests are failing? IF it's Test 7 {IMC} then 100% raise the CPU NB Voltage. edit: Test 7 is all about the CPU.
m
0
l
August 22, 2011 12:50:22 AM

Thank you all for replies thus far. Much appreciated.

I'm not doing OC and memory is 1333, but I'm not sure what you mean by adding Command Rate. I set the freq and CAS manually and they are at 9-9-9-24-2T according to CPU-Z.

I'm aware the Ripjaws aren't guaranteed but I the Corsair set is, and it failed the same way.

I did try raising the voltages on the RAM but not on CPU NB. So I should be doing that simultaneously? Are there guidelines on the ratio between the two or something like that?

Ah ... now, I have looked all over and had not yet found that Test 7 is CPU related or what exactly Block Move was testing. So, I had narrowed it down to CPU / Mobo. Might it really be CPU ?
m
0
l

Best solution

a c 716 V Motherboard
August 22, 2011 1:26:35 AM

Don't confuse the Chipset voltage with the CPU NB Voltage - some BIOS call it CPU VID Voltage, and this voltage is strictly for the CPU's IMC and has nothing to do with OC the CPU or RAM. The AMD CPU IMC is unfortunately weak and 'touchy' to both voltage, including under voltage, and 16GB is a lot for the IMC to handle.

Let me clarify, Test 7 is about the RAM but it's also how the CPU handles the RAM. Test 7 is tied to the correct CAS Timings, Frequency, IMC stress and any voltage irregularities to the CPU's IMC. Since it wasn't a leap to assume the settings are Auto, and Test 7 is a common failure, I jumped ahead. Most folks who know Memtest would also suggest after several passes to ignore Test 7.
Share
September 1, 2011 2:14:45 AM

I took the system completely apart. Checked all contacts and wires, etc. I then put it all back together. The system still fails Memtest #7 but has been stable under pretty steady use. No BSOD or any other problem despite running, for instance, SC Brood war in Win7 with a VM running Matlab doing number crunching in the background. I also installed a Saphire HD 6870 video card recently and that went off without a hitch.

I'll close this with: disassembled and reassembled machine and that seemed to clear up spurious instability. Best answer was that maybe test #7 isn't so important.
m
0
l
September 1, 2011 2:21:28 PM

UPDATE: POSSIBLE BIOS PROBLEM

I'm not sure how this escaped my attention before. If you go to the Gigabyte link:

http://www.gigabyte.com/products/product-page.aspx?pid=...

You will see that the site states that support for the Phenom II X6 processors begins with BIOS version FGF (which is BETA and not recommended by the site) HOWEVER THE BOARD SHIPS WITH BIOS VERSION _FF_. The box is falsely labeled !! _This_ may explain the difficulties I'd been having.
m
0
l
!