Sign in with
Sign up | Sign in
Your question

Cannot format HDD cannot do anything!

Last response: in Storage
Share
January 5, 2013 11:04:29 PM

Hi All,

I have recently come across a problem whilst trying to install a game update via Steam on my WDC WD1500HLFS-01G6U1 Western Digital 10K Rpm Hard drive. The HDD is a few years old and out of warranty. I have never experienced any issues with it and i don't believe its mechanically faulty.

In short, steam tried to apply an update to the game Counterstrike:GO, that update persistently failed and just kept showing as paused in the GUI. I would try to resume, roll-back and even attempted to reinstall the whole steam client but the problem would persist. After a while the issue got worse and then i couldn't even install Steam.

In a last ditch effort i attempted to backup my D: drive and format it to remove the problem. I tried a full (not quick) format and that failed. Quick formats also fail.

The drive now only detects as RAW File System in Win7 Disk Management. I cannot use chkdsk from cmd prompt as it doesn't work with RAW.

I cannot use Format tool as it just errors stating "Windows was unable to complete the fomat" no error code, nothing.

I have tried using a number of tools but they dont see the drive as its in RAW mode.

Any ideas please, i'm all ears and in a serious pickle as i have now lost my entire drive. Any help appreciated, thanks in advanced guys and gals :hello: 

More about : format hdd

January 6, 2013 10:32:00 AM

fzabkar said:
Try a comprehensive SMART diagnostic. Look for reallocated, pending, or uncorrectable sectors.

HD Sentinel (DOS / Windows / Linux):
http://www.hdsentinel.com/

HDDScan for Windows:
http://hddscan.com/

See this article for SMART info:
http://en.wikipedia.org/wiki/S.M.A.R.T.


Many Thanks for the reply... I think i have completed the test you mention in HDDScan but not HDD Sentinel as i need to pay. I don't mind paying for the software if it's going to fix the or at least diagnose the problem but from the results (screenshot attached) the programs seem to think the HDD is OK even though i am still unable to complete a format?

On HDD Sentinel point 5 it shows as OK, i'm not sure what all the stats mean but as far as i can tell they are pointing toward the HDD not reporting any problems -hence the tick mark. Is there something im doing wrong?

Screeny: http://postimage.org/image/x9ne20lef/
Related resources
January 6, 2013 10:56:23 AM

Did you try to use a bootable live cd like gparted to format the drive?
You can also try using Easeus partiton master. I have had success formatting the drive using this tool when Windows failed to format the drive. Same error as yours.
January 6, 2013 12:27:06 PM

Definitely try gpart ^^^^^
January 6, 2013 7:46:34 PM

Wooohoo! Easeus worked like a charm. I actually already own the software but forgot about it completely. The format operation completed successfully, now i just hope there will not be any further errors when copying data to the drive, if there is i'll post to help others following the thread.

Many thanks to all who contributed :) 
January 6, 2013 7:54:22 PM

Perhaps i spoke too soon :S

Anything i try to install a dialog box appears: "The system administrator has set policies to prevent this installation".

I've not set any policies, perhaps i broke it?
January 6, 2013 8:08:02 PM

Apparently the way round this error is to change the windows Local Security Policy, HOWEVER, Microsoft in all its wisdom saw fit to eliminate this feature from Windows 7 Home Premium, so i'm stuck.
a b G Storage
January 7, 2013 9:57:03 AM

Do an in place Anytime Upgrade to Windows Professional for the difference in price.
or just start over, your system integrity sounds a bit crazy.
January 7, 2013 5:18:36 PM

Scott_D_Bowen said:
Do an in place Anytime Upgrade to Windows Professional for the difference in price.
or just start over, your system integrity sounds a bit crazy.


Well thanks for that Scott... though i don't think my system integrity is crazy at all :pt1cable: 

This issue has come about as a result of a corruption on a data cluster on the HDD, due to a problematic game update via the Steam platform. I don't really see why i should have to upgrade Windows just so i can change over the security policies, it was functioning well before the aforementioned update for well over a year.

Any other suggestions? Reformatting my system will be a mini-nightmare.
January 7, 2013 5:21:59 PM

BTW guys, i did attempt to format the HDD using GParted but it encountered loads of problems. I did screenshot some of them too which i will upload when i get home form work. thanks
January 8, 2013 7:30:52 AM

So after my investigations i've discovered the following:
- There is no way to get the Local Security Policy snap-on enabled in Administrative Tools on Windows 7 Home Premium
- Disabling UAC on my account does not make any difference to my issue
- It is possible to change the settings offered in the LSP snap-on (available only on Win7 Pro & Ultimate editions) by directly editing the registry
- i have am excel sheet with an explanation of all the security settings available in the HKLM section of the registry but am not entirely sure what i need to change to give me back the permissions to install software on my system again
(I will provide the link to the excel sheet soon)
- I am now certain i can get my system functioning back to normal without having to reformat


Any further ideas or a nudge jn the right direction to help me remove the "system administrator has set policies to prevent this information" dialog box would be a massive help.

Thanks in advanced all. :) 
a b G Storage
January 20, 2013 3:03:15 PM

- Move your Steam onto an external HDD.
- Re-install Windows
- Re-install Steam. (To it's own partition perhaps?)
- Move/Copy back from the external HDD.

You won't have to re-download very much via Steam if you do this and it only takes 30 minutes to install Windows.
January 24, 2013 6:22:58 PM

Well its not the reinstalling Windows which takes forever. Its all the other programs, setup and configuration of accounts you know... Anyhow just to close this thread, last night i ended up doing a reformat. It has taken me near on 10 hours to get everything back to normal.
!