Sign in with
Sign up | Sign in
Your question
Solved

Narrowing down a problem.

Last response: in Storage
Share
January 6, 2013 6:56:40 PM

Hi there folks, been lurking for a while and finally decided on making an account on here - admittedly, because I'm in need of some help.

I have my own custom built rig, have had it for over a year now. It has never presented any serious issues up until recently; my system started freezing up randomly and only a hard shutdown and reboot would fix it.

I have 2 drives, a Corsair M4 which I'm using pretty much only as a boot drive, and a Spinpoint which I use for all my storage, from music to my Steam games.

Long story short, I narrowed the problem down to my SSD; installing my OS on the Spinpoint and booting from it has made it stable again, with zero crashes in the last few hours (as opposed to the hourly hang with my SSD).

So now I'm left with the question, is my SSD the actual problem, or the associated controller? Honestly, I figure I could just try the other controllers and repeat the process over and over again, were it not that getting to those other cables would be a major PITA. I'm hoping somebody here has had a similar issue or is more knowledgeable in the matter, so I can solve the problem immediately instead of having to go through the ol' trial and error - nor would I want to spend cash on a new SSD if it's the controller that's causing issues.

A few facts:

- My SSD used SATA3, on an AsRock P67 Extreme4 Gen3 motherboard.

- Windows repair did nothing

- Complete format with a fresh Windows install did nothing

- Diskchecks all turned up clean

- After every crash, I would have to turn off my system completely by holding the power button. Simply using the reset button did nothing, and in fact booting up would fail; the system would give me the "Insert boot media in selected boot drive" line, and just get stuck there. This would keep happening until I used the hard shutdown.

Hope somebody can shed some light on this.. :heink: 

More about : narrowing problem

Best solution

a c 523 G Storage
January 6, 2013 7:36:48 PM

A majority of instability issues are fixed by updating your motherboard's BIOS and SSD's firmware to their latest versions.

The latest BIOS for your motherboard is version 2.20.

Did you mean you have a Crucial M4 rather than Corsair M4?
The latest firmware for the Crucial M4 is 040H.

Your motherboard has four SATA 3 (6Gb/s) ports. Your M4 should be connected to one of the 2 Intel 6Gb/s ports (SATA3_0 or SATA3_1), not one of the Marvel 6Gb/s ports (SATA3_M1 or SATA3_M2), for best performance.

The port your drive is connected to also should be in AHCI mode.
Share
January 6, 2013 7:48:57 PM

I derp'd, I indeed meant Crucial.

My motherboard was up to date, not sure about my SSD. Will look into that.

As for the SATA ports, I'm pretty sure they were connected right all along - I had made sure of that when I first built the system. Although you never know, I'll give it another look tomorrow.

I figured my SSD is just flat out failing rather than experiencing simple instabilities, cause it all started really suddenly and became persistent, whereas last week I had exactly zero issues. I was just playing Max Payne 3, when bam, crash.
m
0
l
Related resources
a c 125 G Storage
January 6, 2013 8:31:46 PM

with ssd sometime a format wont fix a read /write issue have you done a secure erase???
m
0
l
a b G Storage
January 7, 2013 9:54:29 AM

Have you tried just replacing the SATA cable?
- Cheapest, fastest, fixes first.
m
0
l
January 19, 2013 3:11:50 PM

Just a quick update so this can go in the solved bin.

I opened up my case again, cleaned it out thoroughly, checked the connections over and over and made sure the SSD was secured properly.

I then used parted magic to secure wipe it, updated its drivers to the latest ones, did a fresh OS install and...so far, 5 hours of use without a single problem - or a sign of one.

My guess as to what the issue was, is as good as yours. Likely during the last time I opened up my case to clean it out, I may have accidentally loosened the SATA cable from my SSD, causing the repeated failures (I did notice how easy it was to disconnect the cable from the SSD, so it's plausible).
m
0
l
January 19, 2013 9:48:12 PM

Best answer selected by Agilaz.
m
0
l
!