Sign in with
Sign up | Sign in
Your question

NIC MAC defaulting to FF:FF:FF:FF:FF:FF

Last response: in Networking
Share
April 28, 2010 4:57:43 PM

This one is really odd. Old system with DFI Lanparty UF3 250g with onboard nVidia nForce NIC. Athlon 3400+ cpu, etc etc. It stopped connecting to my router all of a sudden and nothing I could do would fix it. Uninstall NIC, reinstall, driver updates, etc. No matter what, it would show as connected to a network, but the MAC wouldn't show up in the list of connected devices in the router tables. I figure it's the nVidia chipset going nuts, scrap the motherboard.

I happened to have an extra of the exact same MB so I move my CPU, RAM and GPU over to the spare, completely wipe drive, fresh install of XP home SP2, reload chipset drivers. Same deal. This time I notice via ipconfig the NIC MAC is all F's (broadcast mode) but this time it's getting an IP from the router that was within the range of the list of the IPs I setup in the DHCP but still not in the router's list of connected devices. The connect status shows a few bytes outgoing, 0 incoming.

What the heck is going on here? Could this really be tied to my CPU? I have a spare athlon 3000+ I can throw in there but I thought I'd see if anyone else had any idea. The last thing I tried was forcing a new MAC of random values in via advanced adapter setup. The new MAC shows up via IPconfig but still no connection.

Bobby

More about : nic mac defaulting

April 29, 2010 4:37:41 AM

Did you try another port on the router?

Did you try another cable?

One quick way to test both would be to take the cable out of the computer and plug in another device and see if it pulls an IP.
April 29, 2010 12:52:29 PM

I tried another router port and cable and it was a long shot anyway since the same port and cable were working fine on an adjacent PC.

I tried swapping the CPU for giggles. Nothing. I tried rebuilding the TCP/IP stack in the cmd. I ended up uninstalling the networking features of XP and then reinstalling and I blanked out my overwritten MAC and it went rightjavascript:%20validform(this); back to FFFFFFFF. This time it wouldn't even pull an IP. Then for one last time I overwrote the MAC and it worked. Totally weird.
Related resources
April 29, 2010 6:28:36 PM

The all "F"'s is not a valid MAC address. That is considered a broadcast frame and your NIC should never get an IP from your router if that's the case.

You need to get that address changed.
April 29, 2010 6:37:09 PM

Yeah, I know, that's why I was shocked to see a valid IP while the MAC was all FF previously. I just can't figure out why the NIC's actual MAC isn't being picked up by the OS. After reinstalling the networking files and manually putting in a random MAC, it worked flawlessly.
April 29, 2010 8:14:42 PM

that is some weird... stuff..
!