Sign in with
Sign up | Sign in
Your question

Not Hitting USB 3.0 Speeds

Last response: in Storage
Share
January 8, 2013 8:18:32 PM

Hi,

I'm been trying to achieve USB 3.0 speeds in my transfering but must be having a driver issue or something. Tried a number of things but am still stuck around the 23 mb/s area.

Laptop: Dell XPS l702x (http://www.dell.com/ie/business/p/xps-l702x/pd)
Motherboard: Dell 0T105W
Hard Drive: Hitachi Touro (http://www.memoryc.com/storage/externalharddrives/1tbhi...)

HDTune says my average transfer rate is 26 mb/s. Definitely connected to my USB3 port. Have tried various drivers from different places but i'm worried I'm missing the RIGHT one. :/  I got SlimDrivers (http://download.cnet.com/SlimDrivers-Free/3000-18513_4-...) which thinks I've have the correct one installed but I'm still not getting the speeds i should be. Any thoughts?

More about : hitting usb speeds

January 9, 2013 6:29:19 AM

If your trying to copy from your USB 3 external HDD, to your internal HDD then the most likely problem is your internal hard drive just isnt capable of going at that speed. Same deal if your taking files off of your internal hard drive.

Dell tends to cheap out as much as they can, and having a poor quality internal hard drive is a very likely story.


You shouldnt need drivers to achieve a decent speed. I'm using a USB 2 Hard drive, and Im easily able to get 40mb/s and have never installed a driver.

Most likely problem: Internal Hard Drive is far too slow to hand your new USB 3 HDD.
a b G Storage
January 9, 2013 6:42:57 AM

Real world USB 3.0 speeds have yet to reach anything close to their theoretical max of 625 MB/s. Even USB2.0 with theoretically max of 35 is lucky to get 1/2 that. There are a couple links in the chain that must be correct to get the best results, and usually someone somewhere cheaps out. There is a wide variation in "3.0" speeds unfortunately, and I would expect that to persist for some time.
a b G Storage
January 9, 2013 6:43:43 AM

Quote:
Wow! Friends! Come take a look! Looking for unique design accessories or cool gadgets for your iPhone? IPhone Accessories absolute lowest price! Not to be missed! http://jkvv.com/s73


Reported. Go curl up and die. :3

That being said, Zigiy hit it right on the head - dell cheaps out on the guts of their computers, so you're likely hitting the maximum transfer speed of your hard drive. Either that or the external enclosure is USB 3.0 but not maxing out the transfer rates, like how most USB 3.0 flash drives are only slightly slower on a USB 2.0 port.
!