Sign in with
Sign up | Sign in
Your question

Good System but low fps while running sc2

Last response: in Graphics & Displays
Share
August 18, 2010 7:50:36 PM

Hello everyone, when ever I run starcraft 2 on ultra settings and I hit a cutscene after a mission there is a fps drop and its annoying I know I have a good comp. So why is this happening. Also every once in awhile it, shall I say flickers with black triangles across the screen but they quickly dissappear. Also sometimes if I alt tab and go back in the fps drop goes away. Any ideas??


i5 quad core at 2.6ghz
2 evga gts 250 running sli with ddr3 1g each also in a pci express 2
i have ddr3 8 gbs of ram
running at 1920 X 1200 resolution
asus motherboard P7H57D-V

if you need any other specs let me know

More about : good system low fps running sc2

a c 236 U Graphics card
August 18, 2010 8:11:02 PM

well SC2 does not support SLI or quad cores so you are basically running a dual core 2.6ghz CPU with a single GTS250. Also cut scenes have a locked FPS wo they will often run at a slower rate then game play. If you really want to increase your FPS, I would overclock your CPU.
m
0
l
Related resources
August 18, 2010 9:50:05 PM

well I went to your first link and it really helped so far as I can tell but I might just turn one off to see if there is a difference. Otherwise your post has helped alot.

ct1615 thankyou as well for the information i didnt even know that.. although thats kinda strange for a high end game to not support sli. Anyways thanks really appreciate it.
m
0
l
a c 236 U Graphics card
August 18, 2010 9:53:52 PM

taylorj0209 said:

ct1615 thankyou as well for the information i didnt even know that.. although thats kinda strange for a high end game to not support sli. Anyways thanks really appreciate it.


it took years for blizzard to support SLI/CF in WoW, dont expect Diablo III to be any different
m
0
l
!