Sign in with
Sign up | Sign in
Your question

HDD stopped working

Last response: in Storage
Share
January 10, 2013 7:07:53 AM

Hello,
i have Western Digital Caviar Green 1TB SATA which i connect to my computer via harddrive bay when i need to back up some files.
It worked flawlessly for 3 years where i would connected it about twice a month and copied some new files on it.
But today, when i tried to put some more files on it windows suddenly reported error about HDD not being connected and i can't get it to work since.
All it does now is blinking red like if it's constantly working, but that is obviously not the case. When i try to boot my PC with that HDD connected the boot will get stucked on the windows splash screen until i turn that HDD off.
The HDD is visible in bios and when i tried to boot from linux live CD it recognized the HDD and asked me if i want to mount it, but when i clicked yes it failed with exit code 13.

More about : hdd stopped working

a b G Storage
January 10, 2013 7:49:07 AM

Try booting from the Linux CD again, then run gparted (partition editor) without mounting the drive.

Otherwise you can download and burn a gparted live cd:
http://sourceforge.net/projects/gparted/files/gparted-l...

From the gparted menu options do a disk check on the drive and see what the report says. If the drive is not available to gparted (or linux) the problem is probably serious and the disk may be dead...
January 10, 2013 5:58:06 PM

Okay, i booted from the gparted iso and the HDD is in fact visible there.


This is what it shows: http://www.freeimagehosting.net/7czov

I suppose i should try the "check" option? i don't want to lose my data stored there.
a b G Storage
January 14, 2013 9:56:47 AM

Well if you want anything to be done about your problem you will have to do something. If you have any bad data on the disk right now, the damage is already done. By running the check you at least have some chance of repairing the broken data, by not doing so you only have a disk that is not recognized by your system...
!