Sign in with
Sign up | Sign in
Your question

Altec Lansing VS2521; No Audio Through Subwoofer

Last response: in Components
Share
December 29, 2010 5:21:07 PM

Hello,

I recently bought an Altec Lansing VS2521 2.1 setup from Tiger Direct and am not receiving any signal to the subwoofer. The satellites play and test fine, but the subwoofer is silent and doesn't pick up any test tones from the OS or Audio Manager. I've tried rolling back driver versions with no success. All power is routed through the sub (right satellite joins subwoofer) and is connected to the system through the green input, so I don't think the unit is defective.

Sound card: Realtek HD Audio (Onboard)
OS: Windows 7 Home Premium 64 Bit

More about : altec lansing vs2521 audio subwoofer

December 29, 2010 5:48:37 PM

Hi,

My speaker setup doesn't have an independent subwoofer connection. The subwoofer feeds power to the right satellite through a 9 pin mini DIN cable, which is why I figure the unit is working as the satellites work well. The only connectors on the sub are the power cable to the wall socket and the mini DIN to the right satellite.

Thanks

* Edit:

2.1 isn't a default option on my setup. Realtek HD Audio Manager also doesn't show my subwoofer on the 2/2.1 channel option:



m
0
l
December 29, 2010 5:53:01 PM

I have this same exact set. Do you have an iPod to plug in and test that way to see if it's a software issue with your PC?
m
0
l
Related resources
December 29, 2010 6:16:26 PM

Hi,

Just tested a mp3 player in the Aux connector and the subwoofer receives audio. Bass sounds great; now it's just a matter of getting the PC to recognize it.
m
0
l
December 29, 2010 6:44:53 PM

zecul505 said:
Hi,

Just tested a mp3 player in the Aux connector and the subwoofer receives audio. Bass sounds great; now it's just a matter of getting the PC to recognize it.


Well the problem here is that the sound card you have outputs high frequencies to the green channel because it thinks it's running in some sort of surround sound mode. Try changing the setting to something like "heaphones" and see if that works. Also, make sure your speakers are plugged into the GREEN port on your soundcard. :) 

OR

Try plugging the speakers into the heaphone jack on the front of your computer.
m
0
l
December 29, 2010 10:40:55 PM

I agree, set the speaker mode to headphones and l;et us know how it works.
m
0
l
!