How to remove write protection on my sandisk cruzer flash drive usb?

i can't disable the write protective on my cruzer blade 4GB pendrive but in my system don't have the StorageDevicePolicies option and this option Control key, and selecting New > Key from the menu also don't have what i suppose do for disable
21 answers Last reply
More about remove write protection sandisk cruzer flash drive
  1. When the required keys in your Registry don't exist, you can create them manually, then enter the required value manually in the right-hand pane.

    The outcome will be just the same as if the keys were already there.

    There's a short tutorial on that here: http://www.computerhope.com/issues/ch001349.htm
  2. My only question is: after I do all this then what? I followed all these steps and had to create the key manually, however, the value was already set to a "0". So is that it from there? That is supposed remove the write protection? 'Cause it didn't work for me! :( This is getting very frustrating!! :fou:
  3. mohan_75 said:
    i can't disable the write protective on my cruzer blade 4GB pendrive but in my system don't have the StorageDevicePolicies option and this option Control key, and selecting New > Key from the menu also don't have what i suppose do for disable
  4. HerineKitty789 said:
    You could disable the write protection as below:
    1. Plunge this drive or memory card to a computer. (Of course, you should use a card Reader to connect your memory card.)
    2. Click “Start” on the taskbar to open “Run” and type in “regedit”.
    3. Hit “HKEY_LOCAL_MACHINE” to expand “System”.
    4. Find “Current Control Set” in “System” list to click “Control”.
    5. Check whether there is a key named “Storage Device Policies” to change the digit in the “DWORD value” box into "0" and press “OK”.
    But, if you cannot find the key named “Storage Device Policies”, you are supposed to create a one: right click “Control” to create a new key and name it as “Storage Device Policies”=> right click this new key to open “DWORD Value” and name it as “write protect”=> Double click it to change number.
  5. thank you very very much
  6. HerineKitty789 said:
    You could disable the write protection as below:
    1. Plunge this drive or memory card to a computer. (Of course, you should use a card Reader to connect your memory card.)
    2. Click “Start” on the taskbar to open “Run” and type in “regedit”.
    3. Hit “HKEY_LOCAL_MACHINE” to expand “System”.
    4. Find “Current Control Set” in “System” list to click “Control”.
    5. Check whether there is a key named “Storage Device Policies” to change the digit in the “DWORD value” box into "0" and press “OK”.
    But, if you cannot find the key named “Storage Device Policies”, you are supposed to create a one: right click “Control” to create a new key and name it as “Storage Device Policies”=> right click this new key to open “DWORD Value” and name it as “write protect”=> Double click it to change number.
  7. HerineKitty789 said:
    You could disable the write protection as below:
    1. Plunge this drive or memory card to a computer. (Of course, you should use a card Reader to connect your memory card.)
    2. Click “Start” on the taskbar to open “Run” and type in “regedit”.
    3. Hit “HKEY_LOCAL_MACHINE” to expand “System”.
    4. Find “Current Control Set” in “System” list to click “Control”.
    5. Check whether there is a key named “Storage Device Policies” to change the digit in the “DWORD value” box into "0" and press “OK”.
    But, if you cannot find the key named “Storage Device Policies”, you are supposed to create a one: right click “Control” to create a new key and name it as “Storage Device Policies”=> right click this new key to open “DWORD Value” and name it as “write protect”=> Double click it to change number.
  8. i tryed that but its not working to my pen drive
  9. Hi, i tried ur solution... but it dint work out... can someone help?

    HerineKitty789 said:
    You could disable the write protection as below:
    1. Plunge this drive or memory card to a computer. (Of course, you should use a card Reader to connect your memory card.)
    2. Click “Start” on the taskbar to open “Run” and type in “regedit”.
    3. Hit “HKEY_LOCAL_MACHINE” to expand “System”.
    4. Find “Current Control Set” in “System” list to click “Control”.
    5. Check whether there is a key named “Storage Device Policies” to change the digit in the “DWORD value” box into "0" and press “OK”.
    But, if you cannot find the key named “Storage Device Policies”, you are supposed to create a one: right click “Control” to create a new key and name it as “Storage Device Policies”=> right click this new key to open “DWORD Value” and name it as “write protect”=> Double click it to change number.
  10. manojb89 said:
    Hi, i tried ur solution... but it dint work out... can someone help?

    HerineKitty789 said:
    You could disable the write protection as below:
    1. Plunge this drive or memory card to a computer. (Of course, you should use a card Reader to connect your memory card.)
    2. Click “Start” on the taskbar to open “Run” and type in “regedit”.
    3. Hit “HKEY_LOCAL_MACHINE” to expand “System”.
    4. Find “Current Control Set” in “System” list to click “Control”.
    5. Check whether there is a key named “Storage Device Policies” to change the digit in the “DWORD value” box into "0" and press “OK”.
    But, if you cannot find the key named “Storage Device Policies”, you are supposed to create a one: right click “Control” to create a new key and name it as “Storage Device Policies”=> right click this new key to open “DWORD Value” and name it as “write protect”=> Double click it to change number.


  11. mohan_75 said:
    i can't disable the write protective on my cruzer blade 4GB pendrive but in my system don't have the StorageDevicePolicies option and this option Control key, and selecting New > Key from the menu also don't have what i suppose do for disable
  12. I tried this but this didn't disable the write protect from the pendrive.

    HerineKitty789 said:
    You could disable the write protection as below:
    1. Plunge this drive or memory card to a computer. (Of course, you should use a card Reader to connect your memory card.)
    2. Click “Start” on the taskbar to open “Run” and type in “regedit”.
    3. Hit “HKEY_LOCAL_MACHINE” to expand “System”.
    4. Find “Current Control Set” in “System” list to click “Control”.
    5. Check whether there is a key named “Storage Device Policies” to change the digit in the “DWORD value” box into "0" and press “OK”.
    But, if you cannot find the key named “Storage Device Policies”, you are supposed to create a one: right click “Control” to create a new key and name it as “Storage Device Policies”=> right click this new key to open “DWORD Value” and name it as “write protect”=> Double click it to change number.
  13. in change no , which no i chose and now a time i did not disable the write protect from my scan disk pendrive
  14. dghuge dinesh said:
    HerineKitty789 said:
    You could disable the write protection as below:
    1. Plunge this drive or memory card to a computer. (Of course, you should use a card Reader to connect your memory card.)
    2. Click “Start” on the taskbar to open “Run” and type in “regedit”.
    3. Hit “HKEY_LOCAL_MACHINE” to expand “System”.
    4. Find “Current Control Set” in “System” list to click “Control”.
    5. Check whether there is a key named “Storage Device Policies” to change the digit in the “DWORD value” box into "0" and press “OK”.
    But, if you cannot find the key named “Storage Device Policies”, you are supposed to create a one: right click “Control” to create a new key and name it as “Storage Device Policies”=> right click this new key to open “DWORD Value” and name it as “write protect”=> Double click it to change number.


  15. its not working so do u have any other idea
  16. italian_mami said:

    My only question is: after I do all this then what? I followed all these steps and had to create the key manually, however, the value was already set to a "0". So is that it from there? That is supposed remove the write protection? 'Cause it didn't work for me! :( This is getting very frustrating!! :fou:
  17. POSSIBLE SOLUTION.........
    Right click on the Pen Drive in My Computer when inserted and check the properties.
    Under that you will see a read only box. Remove the tick from it and apply.
    Then format the drive and it'll be ready to use.
  18. POSSIBLE SOLUTION.........
    Right click on the Pen Drive in My Computer when inserted and check the properties.
    Under that you will see a read only box. Remove the tick from it and apply.
    Then format the drive and it'll be ready to use.
  19. mohan_75 said:
    i can't disable the write protective on my cruzer blade 4GB pendrive but in my system don't have the StorageDevicePolicies option and this option Control key, and selecting New > Key from the menu also don't have what i suppose do for disable


    After much research, I have stumbled across something that actually worked!

    Click on 'Start' --> 'Run' --> type in 'regedit' and press enter.
    Search for HKEY_LOCAL_MACHINE
    Scroll down the list and click on SYSTEM
    Click on CurrentControlSet
    Click on Policies
    Click on Microsoft
    Click on FVE
    In the panel on the right side, if the values for either FDVDenyWriteAccess OR RDVDenyWriteAccess are anything other than '0x00000000 (0)', right click and then click on 'Modify', then enter '0' and press Enter.
    Remove the flash drive and reinsert. You can now copy to or write to the flash drive.

    I am using Windows 7 Professional SP-1 64-bit
  20. I'm runing on windows 10 and i can't find the "Storage Device Policies" !!!

    rksingh620 said:
    HerineKitty789 said:
    You could disable the write protection as below:
    1. Plunge this drive or memory card to a computer. (Of course, you should use a card Reader to connect your memory card.)
    2. Click “Start” on the taskbar to open “Run” and type in “regedit”.
    3. Hit “HKEY_LOCAL_MACHINE” to expand “System”.
    4. Find “Current Control Set” in “System” list to click “Control”.
    5. Check whether there is a key named “Storage Device Policies” to change the digit in the “DWORD value” box into "0" and press “OK”.
    But, if you cannot find the key named “Storage Device Policies”, you are supposed to create a one: right click “Control” to create a new key and name it as “Storage Device Policies”=> right click this new key to open “DWORD Value” and name it as “write protect”=> Double click it to change number.


  21. I was having the same problem. I couldnt format, couldnt regedit, couldnt cmd prompt it, etc., So I went to Scandisk Cruzers website and and found some answers to our issue. We are getting the error because there are corrupted files on the flash drive so it does it automatically and there is no way to reverse it. So I would copy whatever you need off of it and destroy & toss it.But make sure you tried everything else first.

    Below is pasted from their website:http://kb.sandisk.com/app/answers/detail/a_id/8656/kw/write%20protected

    Write Protect Error on USB Flash Drives

    How do I fix a Write Protect error?

    Write protection errors occur when a flash drive detects a potential fault within itself. The drive will go into write-protected mode to prevent data loss. There is no method to fix this. To verify the issue is related to the flash drive and not your computer we recommend that you try plugging the USB drive into another port on your computer. You should also try the drive on another computer if possible.


    mohan_75 said:
    i can't disable the write protective on my cruzer blade 4GB pendrive but in my system don't have the StorageDevicePolicies option and this option Control key, and selecting New > Key from the menu also don't have what i suppose do for disable
Ask a new question

Read More

Flash Media Sandisk Flash Drive Write Protection Storage