Sign in with
Sign up | Sign in
Your question

5770 crossfire problem

Tags:
  • Radeon
  • Crossfire
  • Graphics
Last response: in Graphics & Displays
Share
August 21, 2010 8:00:00 PM

I recently bought a second XFX 5770 1GB to crossfire with my other card (also a XFX 5770) after plugging everything in and attaching the crossfire bridge, the crossfireX tab in CCC never showed up. I had this happen to me before with two 4670's a year a ago when i upgraded to Windows 7 64 bit. So i did what I did with the 4670's and went back to vista 64 bit. However with the 5770's this didn't work so i have cleaned out all the old drivers and installed the latest ones but nothing. I can't enable crossfire. The second 5770 is showing up in the CCC device manager so the PCI-e slot is working fine.

I have a Dell Xps 630i with a Nvidia 650i SLI motherboard.

More about : 5770 crossfire problem

August 21, 2010 8:32:43 PM

are you sure that your board supports Crossfire? and not just SLI?
m
0
l
August 21, 2010 9:18:05 PM

CrysisComa said:
are you sure that your board supports Crossfire? and not just SLI?


Yep im sure because i have had those two 4670's running in crossfire when i first got the computer.
m
0
l
Related resources
August 21, 2010 10:15:44 PM

When you cleaned out the old drivers, did you do this with a utility? Or just "Uninstall" them? Use something like Driver Sweeper to remove them completely (going into Safe Mode, etc).

Is it possible any BIOS settings have been changed since? Or any BIOS update/flashing? Cause that usually sets things to default, and you might want to check settings there.

Other than that, you can try different versions of the ATI drivers to see if another older/newer version works.
m
0
l
August 21, 2010 11:00:20 PM

jerreece said:
When you cleaned out the old drivers, did you do this with a utility? Or just "Uninstall" them? Use something like Driver Sweeper to remove them completely (going into Safe Mode, etc).

Is it possible any BIOS settings have been changed since? Or any BIOS update/flashing? Cause that usually sets things to default, and you might want to check settings there.

Other than that, you can try different versions of the ATI drivers to see if another older/newer version works.



Yep I actually used Driver Sweeper I have reset the BIOS to its defaults after overclocking the CPU a few weeks ago. I also tried different versions of the ATI drivers and the drivers that came with the cards.
m
0
l
August 21, 2010 11:01:09 PM

Also im not sure if this is relevant but one of the cards is an egg cooler while the other is the original revision can that cause problems?
m
0
l
August 22, 2010 4:51:35 AM

no iv used crossfire with the two different types. type and brand dont matter.

also i had this same issue at first. make SURE both cards are firmly in their Pci-e slots.
m
0
l
!