Sign in with
Sign up | Sign in
Your question

Cannot connect to some wireless networks

Last response: in Wireless Networking
Share
July 30, 2010 3:13:09 AM

Hi all,

I have an Acer Aspire 7740G-624G50MN with built-in Atheros AR5B93 802.11b/g/n wireless adapter.
Router model is: Netgear WGT624 v3.

I manage to connect to most of the wireless networks, but in some rare cases I can't connect to some networks.
Currently, I'm staying at a place where I cannot connect to the wireless network and it bothers me.

I tried:
-reseting the router.
-connecting from a freinds laptop, which has a different wireless adapter, which is 802.11b (not N like mine) and it works fine. Therefore I assume that the problem is in my wireless adapter/windows settings/compatibility settings.
-tried different type of encryption settings (WEP, WPA, no encryption at all)
-tried different channels and other options in the router regarding wireless.
-there's no MAC filtering on the router.
-I am able to connect with a LAN cable, then it works fine.

The error message I get is simply: Windows was unable to connect to 'network name'.

Anyone has any ideas?

Thanks.
Anonymous
a b F Wireless
July 30, 2010 7:52:20 AM

Presumably you tried changing the wireless mode in the router. Alternatively, the firmware on the router may need updating -- follow the instructions on the Netgear site to the letter.

There are issues between generations of wireless equipment ( though usually older wireless adapters not working with newer routers despite setting mixed mode) .

I wouldn't be surprised if the clue is that your friends older adapter is connecting.
m
0
l
July 30, 2010 8:01:55 PM

I checked now, it's the newest firmware for this model: V2.0.26_1.0.1NA
m
0
l
Related resources
Anonymous
a b F Wireless
November 15, 2010 2:39:16 PM

Hello! A friend of mine had the same problem. He went back to the store where he bought it en they fixt it. The internetadapter wasnt good installed. It was just laying free in the laptop.

Greetzz!
m
0
l
November 22, 2010 5:44:52 PM

Quote:
Hello! A friend of mine had the same problem. He went back to the store where he bought it en they fixt it. The internetadapter wasnt good installed. It was just laying free in the laptop.

Greetzz!


As I explained above, it works with all networks, except this one, so I assume it's not just laying in the laptop..
m
0
l
Anonymous
a b F Wireless
October 26, 2012 10:46:35 AM

Same problem:
office cca 10 clients (not at time) all working.

old AP CISCO WAP4410N
security WPA2 personal,

new HP Probook 4540, with Atheros b/g/n Wifi - only this one cannot discover the access point, it show it for very short time on start and never connect.

I saw similar behavior on some other computers and APs.

Thanks Google, I read meny advices but no solution. I thin it is OS Windows 7 bug.

Jiri
m
0
l
October 26, 2012 11:40:50 AM

There should be an option to force your wireless card into b or g mode. I've found that N mode can be finicky between some cards and routers. If you disable N mode on the card (or even n and g if that's an option), it may force them to sidestep that issue. If you're using the basic Windows wireless client that'll be kinda irritating though, as, even if this works, you'll want to re-enable N mode later so that you can leverage it on other networks.
m
0
l
October 26, 2012 11:42:29 AM

Quote:
Same problem:
office cca 10 clients (not at time) all working.

old AP CISCO WAP4410N
security WPA2 personal,

new HP Probook 4540, with Atheros b/g/n Wifi - only this one cannot discover the access point, it show it for very short time on start and never connect.

I saw similar behavior on some other computers and APs.

Thanks Google, I read meny advices but no solution. I thin it is OS Windows 7 bug.

Jiri

You can manually enter a network if discovery fails. Many people do this for added security anyway. Just go to "manage wireless networks" and click Add. Make sure you check "connect even when network is not broadcasting". You'll have to get all the settings and name right after that, but this might fix you...
m
0
l
!