Sign in with
Sign up | Sign in
Your question

XFX Radeon HD 5770 crashing system on wakeup

Last response: in Graphics & Displays
Share
August 23, 2010 2:17:15 AM

My new system has been running smooth for about a month ago but today I started experiencing the same issue it seems a lot of people have with this card and Win7-64bit.

After completely rebooting the system there doesn't seem to be any trouble, but if I let it go to sleep and then wake it up, the screen starts to shake and glitch after a few seconds, and then the whole screen turns into vertical grey bars.

I have the latest version of CCC from the ATI website so I don't know what the problem could be.
August 23, 2010 2:21:55 AM

I have this exact issue with my HTPC which has a 5770. i've searched around but been unable to find a decent solution. other than turning off power saving features, which for me at least is not an option.



August 23, 2010 2:39:08 AM

I've never messed with the clocks on this card before because I don't know a lot about GPU overclocking. Looks like that might be my only option.
Related resources
October 23, 2010 6:09:09 PM

SUCCESS in fixing my HD 5770 crashes! No crashes at all for several days.

I've had the same HD 5770 crashing problems as very many people - upon reboot or waking from sleep, I got verticle lines and hanging the system. Sometimes it would crash and self recover; occasionally the BSOD.

Here's what I did. XFX suggested manual settings of 850/1200MHz in the CCC Tray Tools. I didn't even know that Tray Tools existed in the ATI console!

First update to the most recent Catalyst. Then open the Catalyst Control Center, "Advanced" not Basic view. Then click on the "Graphics" drop down menu and selected "ATI Overdrive". (Even though I don't Overclock anything). Then click on "Auto-Tune". The utility takes several minutes, but less than an hour to complete. But it allowed me to multitask while it was running. There will be verticle colored lines on the screen during the Auto-Tune procedure. But windows doesn't hang in the process.

When Auto-Tune eventually completed, my XFX HD 5770 functioned perfectly, without crashes for the first time since I installed it in Feb, 2010. I find it to be an excellent card when it isn't annoying you with constant crashing.

Here's my set up:

CASE SILVERSTONE RAVEN 1-BW
MB GIGABYTE GA-X58A-UD3R
VGA XFX HD-577A-ZNFC HD5770
PSU CORSAIR CMPSU-750HX 750W
CPU INTEL CORE I7 920 2.66G 45N
MEM 2Gx3 CORSAIR TR3X6G1333C9
HD 1T WD 7K 32M SATA2 WD1001FALS
WIN PRO 7 64-BT

Hope this helps.

Lazy-B

JANUARY 15, 2011 UPDATE:

After updating my ATI driver and Catalyst, my HD 5770 was back to its old tricks. Crashing on every reboot, crashing upon waking from sleep, crashing in heavy use (games). This time Autotune was no help. I dug a little deeper and found this from suat...

"suat 04-06-2010 at 09:32:10 AM
I also have a Radeon HD5770. I was getting frequent TDR issues when I was at the desktop or browsing the internet. Nothing serious. ( TDR is Timeout Detection and Recovery, a feature introduced first with Windows Vista to overcome gfx card problems in earlier OSs, which then turned out be the problem itself. )

Later I learned over the internet that people increased the idle ( 2D ) clock speeds to overcome the 2D crashes. Therefore, I followed them and increased 2D clocks thru the profile thing.

I increased core clock from 157 MHz to 200 MHz and memory clock from 300 MHz to 400 MHz ( I got at these figures by trial and error ). Now everything is perfect.

People having 2D problems with HD 5xxx series cards, please check first if your PSU complies with version 2.2 and then increase 2D clocks.

Hope the above is helpful.

Regards

Pasted from <http://www.tomshardware.com/forum/283018-33-5770-crashs...; "

I tried this and so far it works perfectly. No crashing during reboots, waking from sleep or in games. On my machine, ATI Overdrive doesn't work to access the core and memory clock from within CCC or in and independant installation. But MSI Afterburner works great.
October 25, 2010 7:13:37 PM

Quote:
FIRST.
go into advanced power options, look for hybrid sleep and disable it...
try that first and see what happens before you try anything else.
you can also go through the advanced power options and edit a few things like
hdd and usb settings but right now just disable hybrid sleep.

do not download catalyst drivers, change settings in catalyst control center, overdrive or auto-tune.
disable hybrid sleep first then try.


Thanks for the tip. Had my problem not been fixed, I'd give it a try. But since my card isn't crashing anymore, and I like the hybrid sleep feature, I'll probably just keep going as is. Now I'm down to just one problem with the sleep - disappearing hard drives after waking!
November 30, 2010 12:26:31 AM

Best answer selected by inate36.
!