Closed

[SOLVED] Samsung 840 Pro-- very slow in new build. Why?

So for the first time ever I built my new system yesterday and cloned my old SSD using Samsung's migration software. I'm now booting from my new (supposed to be) blazing fast Samsung 840 Pro. Here are my rather craptastic benchmarks:

AS SSD Benchmark 1.7.4739.38088
------------------------------
Name: Samsung SSD 840 PRO Seri SCSI Disk Device
Firmware: DXM0
Controller: mvs91xx
Offset: 103424 K - OK
Size: 238.47 GB
Date: 1/15/2013 10:11:39 AM
------------------------------
Sequential:
------------------------------
Read: 314.97 MB/s
Write: 165.29 MB/s
------------------------------
4K:
------------------------------
Read: 25.77 MB/s
Write: 46.53 MB/s
------------------------------
4K-64Threads:
------------------------------
Read: 196.10 MB/s
Write: 104.72 MB/s
------------------------------
Access Times:
------------------------------
Read: 0.131 ms
Write: 0.074 ms
------------------------------
Score:
------------------------------
Read: 253
Write: 168
Total: 553
------------------------------

I can't figure out why it's so slow. I have the Samsung (and my old SSD) attached to an ASUS Sabertooth X79, 6gb Marvell port. These 2 ports are used for the "SSD caching" function, which I have no interest in using since I have 2 SSDs-- however the mobo manual says:

"For regular usage, the SATA6G_E1/E2 connectors are recommended for data drives."

I have them hooked there, but they are Marvell and my other options are 2 Intel 6g ports, which I understand are faster. Why would ASUS recommend using a slower port for regular SSD data drive usage? Or did I misunderstand the instructions?

I also have verified via BIOS and registry that I am running in the faster AHCI, and I've run Samsung's performance tweaker software that it came with.

Granted, I'm a noob to computer building and am surprised this thing even turned on the first time, but I'm really at a loss...
35 answers Last reply
More about solved samsung slow build
  1. You need to connect your SSDs to the native Intel SATA3 (6Gbps) ports for optimal performance.
  2. Despite ASUS's manual recommendation? What kind of performance increase are we talking about by switching?
  3. I have a similar Asus mobo and the manual contains similar info. However, I think their wording is less than clear. Essentially, for the best performance, you need to use the Intel ports. The Marvell ports simply don't perform as well.

    There are 100s of threads on the forums to support this recommendation.

    Good luck!
  4. I'll try it and let you know if it helps.
  5. COLGeek is 100% correct, and as far as the recommendation, ASUS recommends the Marvell ports for data drives -- i.e. not the OS SSD, but secondary SSDs if you are out of Intel SATA III ports because the Marvell are slower.
  6. Marvell controllers are slower than the native Intel SATA2 (3Gbps) ports, as recommended above don´t use them.

    Use the 840 Pro for your OS and main game and programs, and the spare SSD for other secondary games and programs -- you won´t need use caching.
  7. Ok so I switched to the Intel 6gb ports and I saw significant improvement on sequential-- but my write times just went through the ceiling. What the heck?

    Ideas?

    AS SSD Benchmark 1.7.4739.38088
    ------------------------------
    Name: ATA Samsung SSD 840 SCSI Disk Device
    Firmware: 4B0Q
    Controller: iaStorA
    Offset: 103424 K - OK
    Size: 238.47 GB
    Date: 1/15/2013 12:29:36 PM
    ------------------------------
    Sequential:
    ------------------------------
    Read: 509.11 MB/s
    Write: 306.63 MB/s
    ------------------------------
    4K:
    ------------------------------
    Read: 26.78 MB/s
    Write: 2.29 MB/s
    ------------------------------
    4K-64Threads:
    ------------------------------
    Read: 293.47 MB/s
    Write: 18.72 MB/s
    ------------------------------
    Access Times:
    ------------------------------
    Read: 0.101 ms
    Write: 1.703 ms
    ------------------------------
    Score:
    ------------------------------
    Read: 371
    Write: 52
    Total: 612
    ------------------------------
  8. COLGeek said:
    You need to connect your SSDs to the native Intel SATA3 (6Gbps) ports for optimal performance.


    ^This, the Marvell controllers are not very good and won't give you full speed. I don;t think they support TRIM either.
  9. Hi, the post just above yours shows my results after switching to the Intel ports. I saw improvement in sequential (still nothing like advertised speed) but my write times went way down for whatever reason -- something is still wrong.

    Anyone have an idea why?
  10. jjkrogs said:
    Hi, the post just above yours shows my results after switching to the Intel ports. I saw improvement in sequential (still nothing like advertised speed) but my write times went way down for whatever reason -- something is still wrong.

    Anyone have an idea why?


    Your write times are extremely low, no idea why something like that would happen. Try Googling and see if someone else has had a similar problem.
  11. Is your SSD firmware up to date? Also, did you load the latest Intel chipset drivers?
  12. I´d go for a completely clean OS installation.
  13. I recommend a clean install, as you most likely used the ahci driver for the marvel ports and not the intel ports.
  14. Ok... So I've spent the better part of yesterday and this AM completely wiping clean the Samsung and doing a full clean install with all the latest drivers for... Everything. Here's what I found out:

    Immediately after installing windows disk-- before any drivers or anything were updated, I was getting solid read/write speeds.

    I checked again about halfway through the process, and again, all was good.

    I then download about 120 "windows updates", Kaspersky and a handful of other basic drivers that wouldnt affect the SSD (printer, keyboard, etc)...

    And now I'm back to horrid random write speeds. If I had to guess, Windows update did it somehow as that seems to be when I noticed a significant dropoff in performance during a bunch of "Net framework" crap which I have no idea what that's for.

    Anyway, I'm kinda pissed at this point. While I'm happy to have a clean install of Win 7, I need to get this SSD fixed. There's gotta be a setting somewhere I am missing, since I know the thing works the way it's supposed to PRIOR to Windows update.
  15. Did you run the Samsung Magician to check the drive?
  16. RealBeast said:
    Did you run the Samsung Magician to check the drive?


    I did. All 3 times I used the "optimization" function which then goes into the benchmark. I also updated the firmware
  17. jjkrogs said:
    Ok... So I've spent the better part of yesterday and this AM completely wiping clean the Samsung and doing a full clean install with all the latest drivers for... Everything. Here's what I found out:

    Immediately after installing windows disk-- before any drivers or anything were updated, I was getting solid read/write speeds.

    I checked again about halfway through the process, and again, all was good.

    I then download about 120 "windows updates", Kaspersky and a handful of other basic drivers that wouldnt affect the SSD (printer, keyboard, etc)...

    And now I'm back to horrid random write speeds. If I had to guess, Windows update did it somehow as that seems to be when I noticed a significant dropoff in performance during a bunch of "Net framework" crap which I have no idea what that's for.

    Anyway, I'm kinda pissed at this point. While I'm happy to have a clean install of Win 7, I need to get this SSD fixed. There's gotta be a setting somewhere I am missing, since I know the thing works the way it's supposed to PRIOR to Windows update.


    Go int your BIOS and make sure that you enabled AHCI and that your drive is in SATA mode instead of IDE or some other crap. It comes preset as IDE, so that could be the problem.

    If you haven't done that, and you get error messages after you do. Follow this: http://support.microsoft.com/kb/922976#method1
  18. jjkrogs said:
    I did. All 3 times I used the "optimization" function which then goes into the benchmark. I also updated the firmware
    Have you run the SMART diagnostic tool? If so, do you see any SMART errors?
  19. There are 2 functions on Samsung Magician tool:

    One is the Performance Optimization, which leads you to Benchmark feature.

    Another is the OS Optimization: have you used that one too? In this one there is also a feature called Temporary File Cleanup that should be applied.
  20. jemm said:
    There are 2 functions on Samsung Magician tool:

    One is the Performance Optimization, which leads you to Benchmark feature.

    Another is the OS Optimization: have you used that one too? In this one there is also a feature called Temporary File Cleanup that should be applied.


    You knowb I did do the OS optimization but actally didn't hit the Temp file cleanup button as I figured that was a basic disk cleanup function I could do via the os. I will try that when I get home. Man that would rock if it were that easy...
  21. Nope, didn't help.
  22. I've also done the following checks: Trim is active, as is caching (2 common issues that cause similar slow speeds). I've done several tweaks found in SSD optimization guides.

    Still stumped.
  23. Ok, something I did within the last hour fixed it... Though still not near what advertised speeds are supposed to be, I'm not complaining. This is more than adequate. I have a few ideas as to what it was if anyone's interested, but otherwise this thread is...

    Solved!

    AS SSD Benchmark 1.7.4739.38088
    ------------------------------
    Name: ATA Samsung SSD 840 SCSI Disk Device
    Firmware: 4B0Q
    Controller: iaStorA
    Offset: 234496 K - OK
    Size: 238.47 GB
    Date: 1/17/2013 10:52:10 AM
    ------------------------------
    Sequential:
    ------------------------------
    Read: 526.48 MB/s
    Write: 449.11 MB/s
    ------------------------------
    4K:
    ------------------------------
    Read: 37.05 MB/s
    Write: 112.58 MB/s
    ------------------------------
    4K-64Threads:
    ------------------------------
    Read: 368.67 MB/s
    Write: 293.50 MB/s
    ------------------------------
    Access Times:
    ------------------------------
    Read: 0.048 ms
    Write: 0.029 ms
    ------------------------------
    Score:
    ------------------------------
    Read: 458
    Write: 451
    Total: 1153
    ------------------------------
  24. Keep in mind that you really can't directly compare your system to a benchmark system unless they are identical. Of course, you can use the indirect comparisons to get an idea of how well a system should/could perform.

    Good job optimizing your particular config.
  25. jjkrogs said:
    Ok, something I did within the last hour fixed it... Though still not near what advertised speeds are supposed to be, I'm not complaining. This is more than adequate. I have a few ideas as to what it was if anyone's interested, but otherwise this thread is...

    Solved!

    AS SSD Benchmark 1.7.4739.38088
    ------------------------------
    Name: ATA Samsung SSD 840 SCSI Disk Device
    Firmware: 4B0Q
    Controller: iaStorA
    Offset: 234496 K - OK
    Size: 238.47 GB
    Date: 1/17/2013 10:52:10 AM
    ------------------------------
    Sequential:
    ------------------------------
    Read: 526.48 MB/s
    Write: 449.11 MB/s
    ------------------------------
    4K:
    ------------------------------
    Read: 37.05 MB/s
    Write: 112.58 MB/s
    ------------------------------
    4K-64Threads:
    ------------------------------
    Read: 368.67 MB/s
    Write: 293.50 MB/s
    ------------------------------
    Access Times:
    ------------------------------
    Read: 0.048 ms
    Write: 0.029 ms
    ------------------------------
    Score:
    ------------------------------
    Read: 458
    Write: 451
    Total: 1153
    ------------------------------


    What do you think fixed it?
  26. BloodyDream3 said:
    What do you think fixed it?


    Went through some steps from this guide:

    http://www.overclock.net/t/1156654/seans-windows-7-install-optimization-guide-for-ssds-hdds

    One of these steps (not sure which one or perhaps all) fixed it:

    1) Turned off hibernation "powercfg -h off" in command prompt

    2) Turned off drive indexing in C drive

    3) Shrunk page file, which was set at my full 16g ram, to 800 min/1024 max

    4) Switched to "high performance" power option in Windows, and told HD never to shut down.

    5) Although write caching was turned on, I turned off Windows caching (2nd check box) in device manager. I had also heard that sometimes the check box for write caching can get "stuck" so I unchecked it, hit ok, and rechecked it, hit ok.

    6) I verified that TRIM was active this way:

    Quote:
    1.Open the Start Menu, type CMD
    2.Right click the icon and Run as Administrator
    3.Type fsutil behavior query disabledeletenotify
    DisableDeleteNotify = 1 (Windows TRIM commands are disabled)
    DisableDeleteNotify = 0 (Windows TRIM commands are enabled



    That's all I got...
  27. jjkrogs said:
    Went through some steps from this guide:

    http://www.overclock.net/t/1156654/seans-windows-7-install-optimization-guide-for-ssds-hdds

    One of these steps (not sure which one or perhaps all) fixed it:

    1) Turned off hibernation "powercfg -h off" in command prompt

    2) Turned off drive indexing in C drive

    3) Shrunk page file, which was set at my full 16g ram, to 800 min/1024 max

    4) Switched to "high performance" power option in Windows, and told HD never to shut down.

    5) Although write caching was turned on, I turned off Windows caching (2nd check box) in device manager. I had also heard that sometimes the check box for write caching can get "stuck" so I unchecked it, hit ok, and rechecked it, hit ok.

    6) I verified that TRIM was active this way:

    Quote:
    1.Open the Start Menu, type CMD
    2.Right click the icon and Run as Administrator
    3.Type fsutil behavior query disabledeletenotify
    DisableDeleteNotify = 1 (Windows TRIM commands are disabled)
    DisableDeleteNotify = 0 (Windows TRIM commands are enabled



    That's all I got...


    How do you switch to high performance.

    Also, since you turned Hibernation off, make sure that you delete the space that is reserved for that. I don't remember exactly how to, but I'll find the thread that I started where someone told me how to.


    Correction: I'm pretty sure that turning hibernate off does that automatically. Check and make sure though. Go to your C:/ and make sure that there isn't as hiberfile.sys
  28. BloodyDream3 said:
    How do you switch to high performance.



    Under your power options in Windows 7. It initially only shows you power saver and balanced, but there's an arrow underneath to access the "high performance" option. Then you have to manually go into the advanced setup to tell it to keep your HD/SSD turned on always.
  29. I've got the same drive with similar results, IMHO I don't anyone will come close to the marketed speeds.

    I personally scoured the *toobs* to optimize the drive. You may want to run the Samsung SSD Magician software and select the *Over-Provision* option and use the default settings. This may improve performance.

    AS SSD Benchmark 1.7.4739.38088
    ------------------------------
    Name: Samsung SSD 840 PRO Series
    Firmware: DXM04B0Q
    Controller: storahci
    Offset: 359424 K - OK
    Size: 238.47 GB
    Date: 2013-01-22 10:02:10 PM
    ------------------------------
    Sequential:
    ------------------------------
    Read: 519.68 MB/s
    Write: 486.38 MB/s
    ------------------------------
    4K:
    ------------------------------
    Read: 26.33 MB/s
    Write: 53.76 MB/s
    ------------------------------
    4K-64Threads:
    ------------------------------
    Read: 370.12 MB/s
    Write: 287.64 MB/s
    ------------------------------
    Access Times:
    ------------------------------
    Read: 0.076 ms
    Write: 0.051 ms
    ------------------------------
    Score:
    ------------------------------
    Read: 448
    Write: 390
    Total: 1074
    ------------------------------

    AS SSD Benchmark 1.7.4739.38088
    ------------------------------
    Name: Samsung SSD 840 PRO Series
    Firmware: DXM04B0Q
    Controller: storahci
    Offset: 359424 K - OK
    Size: 238.47 GB
    Date: 2013-01-22 10:02:42 PM
    ------------------------------
    16MB
    ------------------------------
    Read: 32.48 iops
    Write: 30.40 iops
    ------------------------------
    4K:
    ------------------------------
    Read: 6740 iops
    Write: 13763 iops
    ------------------------------
    4K-64Threads:
    ------------------------------
    Read: 94750 iops
    Write: 73636 iops
    ------------------------------
    512B
    ------------------------------
    Read: 13162 iops
    Write: 19633 iops
    ------------------------------
    Score:
    ------------------------------
    Read: 448
    Write: 390
    Total: 1074
    ------------------------------
  30. I had a similar problem with my Samsung 840. My Read benchmarks were very low. The steps I took to solve (thanks to this thread):


    1) SSD Magician - Over Provisioning > Shrink (default value)
    2) http://support.microsoft.com/kb/922976#method1 (Fixed the AHCI blue-screen problem)
    3) Reboot.
    4) BIOS > On-Chip SATA Type > AHCI. (Previously only booted on 'Native IDE')
    5) Benchmark. Success!


    OLD BENCHMARKS
    Seq Read: 409mb
    Seq Write: 248mb
    Ran. Read: 6810
    Ran. Write: 20895


    NEW BENCHMARKS
    Seq Read: 512mb
    Seq Write: 243mb
    Ran. Read: 36555
    Ran. Write: 21396


    No reformatting needed. Thank you to everyone who posted help in this thread. Hopefully all can see this and these steps work for them as well.
  31. Rock on!
  32. Hi Ultimatt19, your iops are still low.

    I have more or less the same iops:
    Sequential Read: 551 MB's
    Sequential Write: 525 MB's (first time score above 500MB/s.. yesterday it was around 460MB/s, but I did do a firmware update...)
    Random Read: 39795 IOPS
    Random Write: 24282 IOPS

    The random Read and Write should however be much higher right? Up to 100k for read and 90k for write..

    Anybody idea's why these values are so low?

    Current firmware: DXM04B0Q

    Ultimatt19 said:
    I had a similar problem with my Samsung 840. My Read benchmarks were very low. The steps I took to solve (thanks to this thread):


    1) SSD Magician - Over Provisioning > Shrink (default value)
    2) http://support.microsoft.com/kb/922976#method1 (Fixed the AHCI blue-screen problem)
    3) Reboot.
    4) BIOS > On-Chip SATA Type > AHCI. (Previously only booted on 'Native IDE')
    5) Benchmark. Success!


    OLD BENCHMARKS
    Seq Read: 409mb
    Seq Write: 248mb
    Ran. Read: 6810
    Ran. Write: 20895


    NEW BENCHMARKS
    Seq Read: 512mb
    Seq Write: 243mb
    Ran. Read: 36555
    Ran. Write: 21396


    No reformatting needed. Thank you to everyone who posted help in this thread. Hopefully all can see this and these steps work for them as well.
  33. Here are my numbers from running Performance Benchmark four times in one hour using Samsung Magician version 4.0 on an 840 Pro (firmware DXM04B0Q).

    Seq. Read: 551/508/424/531 MB/s (540)
    Seq. Write: 425/400/395/392 MB/s (520)
    Ran. Read: 82359/70806/77353/74673 IOPS (100100)
    Ran. Write: 75810/73053/69157/68330 IOPS (90000)

    The numbers in parentheses () are the optimistic maximum according to Magician.

    I don't know why there is so much variability in the numbers reported even though I made no system changes (just running Internet Explorer to read this thread).

    I suppose that I should be satisfied with these results because I made the mistake of not looking more closely at SSD issues until after I had loaded Windows 8 Pro, MS Office 2010, Battlefield 3 AND after Norton Internet Security had already silently defragmented the 840 Pro and told me after the fact.

    Defragmenting is unnecessary and could impair SSD performance and lifetime, according to Samsung. Argggh! I don't think I will erase the SSD and start all over again to do things properly and try for improvement.
  34. hmm, your IOPS values are much higher than mine. But my seq read/write are still very good.

    My four runs:

    Runtime: 1:47/
    Seq. Read: 553/552/546/551 MB/s (540)
    Seq. Write: 423/477/451/481 MB/s (520)
    Ran. Read: 38085/40165/39240/39599 IOPS (100100)
    Ran. Write: 23229/24982/24814/24943 IOPS (90000)

    Is it possible that sophos drive encryption is the cause of lower IOPS values?
  35. for me connecting to Intel Sata 3 SOLVED problem. I had it connected to asmadia sata 3
Ask a new question

Read More

SSD Samsung New Build Storage